AWS Lambda
开发人员指南
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

API 参考

本节包含 AWS Lambda API 参考文档。在执行 API 调用时,您需要提供签名以验证请求。AWS Lambda支持签名版本 4。有关更多信息,请参阅 Amazon Web Services 一般参考中的签名版本 4 签名流程

有关该服务的概述,请参阅什么是 AWS Lambda?

可以使用 AWS CLI 探索 AWS Lambda API。本指南提供了几个使用 AWS CLI 的教程。

主题

在使用 SDK 时出现证书错误

由于 AWS 开发工具包使用的是来自计算机的 CA 证书,因此更改 AWS 服务器上的证书可能会导致您在尝试使用开发工具包时无法连接。您可以通过使计算机的 CA 证书和操作系统保持最新来防止出现这些故障。如果您在公司环境中遇到这个问题而且未管理您自己的计算机,则可能需要请求管理员来协助处理更新过程。以下列表显示了最低的操作系统和 Java 版本:

  • 已安装 2005 年 1 月版或更高版本更新的 Microsoft Windows 版本在其信任列表中至少包含一个必需 CA。

  • 带 Java for Mac OS X 10.4 版本 5 的 Mac OS X 10.4 (2007 年 2 月版)、Mac OS X 10.5 (2007 年 10 月版) 及更高版本在其信任列表中至少包含一个必需 CA。

  • Red Hat Enterprise Linux 5 (2007 年 3 月版)、6 和 7 以及 CentOS 5、6 和 7 在其默认信任 CA 列表中至少包含一个必需 CA。

  • Java 1.4.2_12 (2006 年 5 月版)、5 Update 2 (2005 年 3 月版) 以及所有更高版本,包括 Java 6 (2006 年 12 月版)、7 和 8 在其默认信任 CA 列表中至少包含一个必需 CA。

在访问 AWS Lambda 管理控制台或 AWS Lambda API 终端节点时,无论是通过浏览器还是以编程方式,您都需要确保您的客户端计算机支持任何以下 CA:

  • Amazon Root CA 1

  • Starfield Services Root Certificate Authority – G2

  • Starfield Class 2 Certification Authority

可以从 Amazon Trust Services 获得来自前两个颁发机构的根证书,而使您的计算机保持最新是更直接的解决方案。要了解 ACM 提供的证书的更多信息,请参阅 AWS Certificate Manager 常见问题