AWS::ApiGatewayV2::ApiGatewayManagedOverrides IntegrationOverrides - AWS CloudFormation
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

AWS::ApiGatewayV2::ApiGatewayManagedOverrides IntegrationOverrides

IntegrationOverrides 属性覆盖 API 网关托管的集成的集成设置。如果删除此属性,API 网关将恢复默认值。

语法

要在 AWS CloudFormation 模板中声明此实体,请使用以下语法:

JSON

{ "Description" : String, "IntegrationMethod" : String, "PayloadFormatVersion" : String, "TimeoutInMillis" : Integer }

YAML

Description: String IntegrationMethod: String PayloadFormatVersion: String TimeoutInMillis: Integer

属性

Description

集成的描述。

必需:否

类型:字符串

Update requires: No interruption

IntegrationMethod

指定集成的 HTTP 方法类型。

必需:否

类型:字符串

Update requires: No interruption

PayloadFormatVersion

指定发送到集成的负载的格式。对 HTTP API 是必需的。对于 HTTP API,Lambda 代理集成支持的值为 1.02.0。对于所有其他集成,1.0 是唯一受支持的值。要了解更多信息,请参阅使用适用于 HTTP API 的 AWS Lambda 代理集成

必需:否

类型:字符串

Update requires: No interruption

TimeoutInMillis

对于 WebSocket API,自定义超时介于 50 到 29000 毫秒之间;对于 HTTP API,自定义超时介于 50 到 30000 毫秒之间。对于 WebSocket API,默认超时为 29 秒,对于 HTTP API,默认超时为 30 秒。

必需:否

类型:整数

Update requires: No interruption