Amazon CloudWatch
用户指南
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

设置 开发工具包指标

要设置 开发工具包指标,您需要使用开发工具包执行一些步骤,并使用 CloudWatch 代理执行一些步骤。

设置 开发工具包指标

  1. 使用支持 开发工具包指标 的 AWS 开发工具包创建一个应用程序。

  2. 在 Amazon EC2 实例上或您的本地环境中托管您的项目。

  3. 安装并使用最新版本的开发工具包。

  4. 在运行要接收指标的应用程序的 EC2 实例或本地环境中安装 CloudWatch 代理。有关更多信息,请参阅安装 CloudWatch 代理

  5. 为 开发工具包指标 配置 CloudWatch 代理。有关更多信息,请参阅为 开发工具包指标 配置 CloudWatch 代理

  6. 授权 开发工具包指标 收集和发送指标。有关更多信息,请参阅为 开发工具包指标 设置 IAM 权限

  7. 启用 开发工具包指标。可以使用多种方法执行该操作,具体取决于您使用的开发工具包。所有开发工具包的一种通用方法是,将以下内容添加到环境变量中:

    export AWS_CSM_ENABLED=true

    有关其他方法的信息,请参阅开发工具包文档,如下表中所示。

    支持的开发工具包 开发工具包指标 文档

    AWS CLI 1.16.84 或更高版本

    开发工具包指标

    对于适用于 Python 的 开发工具包 (Boto3),AWS CLI 安装说明是相同的。

    适用于 C++ 的 AWS 开发工具包 1.7.47 或更高版本

    开发工具包指标

    适用于 Go 的 AWS 开发工具包 1.16.18 或更高版本

    适用于 Go 的 AWS 开发工具包 中的 开发工具包指标

    AWS SDK for Java 1.11.523 或更高版本(尚不支持 适用于 Java 的 AWS 开发工具包 2.x)

    启用 适用于企业支持的 AWS 开发工具包指标

    AWS SDK for JavaScript in Node.js 2.387 或更高版本

    AWS SDK for JavaScript 中的 开发工具包指标

    适用于 .NET 的 AWS 开发工具包 3.3.440 或更高版本

    启用 开发工具包指标

    适用于 PHP 的 AWS 开发工具包 3.85.0 或更高版本

    适用于 PHP 的 AWS 开发工具包 版本 3 中的 开发工具包指标

    适用于 Python 的 AWS 开发工具包 (Boto3) 1.9.78 或更高版本

    开发工具包指标

    适用于 Ruby 的 AWS 开发工具包 3.45.0 或更高版本

    适用于 Ruby 的 AWS 开发工具包 中的 开发工具包指标