支持的 ElastiCache for Memcached 版本 - Amazon ElastiCache
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

支持的 ElastiCache for Memcached 版本

ElastiCache 支持以下 Memcached 版本,也支持升级到更新的版本。如果升级到更新的版本,请关注那些会导致升级失败的先决条件。

Memcached 版本 1.6.6

ElastiCache for Memcached 添加了对 Memcached 版本 1.6.6 的支持。该版本未新增任何新功能,但包含对 Memcached 1.5.16 的错误修复和累积更新。ElastiCache for Memcached 不包含对 Extstore 的支持。

有关更多信息,请参阅 GitHub 上 Memcached 中的 ReleaseNotes166

Memcached 版本 1.5.16

ElastiCache for Memcached 添加了对 Memcached 版本 1.5.16 的支持。它没有包含任何新功能,但包含了 Memcached 1.5.14Memcached 1.5.15 中的错误修复和累积更新。

有关更多信息,请参阅 GitHub 上 Memcached 中的 Memcached 1.5.16 发布说明

Memcached 版本 1.5.10

ElastiCache for Memcached 版本 1.5.10 支持以下 Memcached 功能:

  • 自动 Slab 重新平衡。

  • 使用 murmur3 算法实现更快的哈希表查找。

  • 经过分段的 LRU 算法。

  • LRU 爬网程序到后台回收内存。

  • --enable-seccomp:一个编译时选项。

它还引入了 no_moderninline_ascii_resp 参数。有关更多信息,请参阅 Memcached 1.5.10 参数更改

自适用于 Memcached 版本 1.4.34 的 ElastiCache 起增加的 Memcached 改进功能包括:

  • 累积修复,例如 ASCII multigets、CVE-2017-9951 和 metadumper 的限制爬网。

  • 通过在达到连接限制时关闭连接来改善连接管理。

  • 改进了超过 1MB 的项大小的项大小管理。

  • 通过将每个项的内存需求减少几个字节来提高性能和减少内存开销。

有关更多信息,请参阅 GitHub 上 Memcached 中的 Memcached 1.5.10 发布说明

Memcached 版本 1.4.34

ElastiCache for Memcached 版本 1.4.34 未在版本 1.4.33 的基础上添加任何功能。1.4.34 版是一个错误修复版本,它大于一般的此类版本。

有关更多信息,请参阅 GitHub 上 Memcached 中的 Memcached 1.4.34 发布说明

Memcached 版本 1.4.33

自版本 1.4.24 起增加的 Memcached 改进功能包括:

Memcached 版本 1.4.24

自版本 1.4.14 起增加的 Memcached 改进功能包括:

  • 使用后台进程的最近最少使用 (LRU) 的管理。

  • 增加了使用 jenkinsmurmur3 作为哈希算法的选项。

  • 一些新的命令和参数。有关列表,请参阅Memcached 1.4.24 增加的参数

  • 修复了几个 Bug。

Memcached 版本 1.4.14

自版本 1.4.5 起增加的 Memcached 改进功能包括:

  • 增强了 Slab 重新平衡功能。

  • 性能和可扩展性方面的改进。

  • 引入了 touch 命令,可在不获取的情况下更新现有项目的过期时间。

  • Auto Discovery – 客户端程序功能,可以自动确定集群中的所有缓存节点,以及启动和维护与所有这些节点的连接。

Memcached 版本 1.4.5

Amazon ElastiCache for Memcached 初始支持的引擎和版本是 Memcached 版本 1.4.5。