Amazon Aurora
Aurora 用户指南 (API 版本 2014-10-31)
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅 Amazon AWS 入门

2018-02-06 版 Amazon Aurora MySQL 数据库引擎更新

版本:2.01

Amazon Aurora MySQL 2.01 已正式发布。以后,Aurora MySQL 2.x 版将与 MySQL 5.7 兼容,Aurora MySQL 1.x 版将与 MySQL 5.6 兼容。

在创建新的 Aurora MySQL 数据库集群 (包括从快照中还原的集群) 时,您可以选择与 MySQL 5.7 或 MySQL 5.6 的兼容性。

您可以将 Aurora MySQL 1.14*、1.15* 和 1.16* 快照还原到 Aurora MySQL 2.01 中。

我们不允许将 Aurora MySQL 1.x 集群就地升级到 Aurora MySQL 2.01 或从 Amazon S3 备份还原到 Aurora MySQL 2.01。我们计划从以后的 Aurora MySQL 2.x 版本中删除这些限制。

该版本的 Aurora MySQL 5.7 已禁用性能架构。请升级到 Aurora 2.03 以提供性能架构支持。

与 Aurora MySQL 5.6 进行比较

在 Aurora MySQL 5.6 中支持以下 Amazon Aurora MySQL 功能,但目前在 Aurora MySQL 5.7 中不支持这些功能。

目前,Aurora MySQL 2.01.1 不支持在 Aurora MySQL 1.16 和更高版本中添加的功能。有关 Aurora MySQL 1.16 版的信息,请参阅2017-12-11 版 Amazon Aurora MySQL 数据库引擎更新

MySQL 5.7 兼容性

Amazon Aurora MySQL 2.01 与 MySQL 5.7 接口兼容并包含一些功能,例如,JSON 支持、空间索引和生成的列。Amazon Aurora MySQL 使用采用 z 顺序曲线的空间索引的本机实现,可以为空间数据集提供比 MySQL 5.7 高 20 多倍的写入性能以及高 10 多倍的读取性能。

Amazon Aurora MySQL 2.01 当前不支持以下 MySQL 5.7 功能:

  • 全局事务标识符 (GTID)

  • 组复制插件

  • 增加的页面大小

  • InnoDB 缓冲池启动时加载

  • InnoDB 全文分析器插件

  • 多源复制

  • 在线缓冲池大小调整

  • 密码验证插件

  • 查询重写插件

  • 复制筛选

  • CREATE TABLESPACE SQL 语句

  • X 协议

Aurora MySQL 2.x 和 Aurora MySQL 1.x 之间的 CLI 差异

  • Aurora MySQL 2.x 的引擎名称为 aurora-mysql;Aurora MySQL 1.x 的引擎名称仍为 aurora

  • Aurora MySQL 2.x 的引擎版本为 5.7.12;Aurora MySQL 1.x 的引擎版本仍为 5.6.10ann

  • Aurora MySQL 2.x 的默认参数组为 default.aurora-mysql5.7;Aurora MySQL 1.x 的默认参数组仍为 default.aurora5.6

  • Aurora MySQL 2.x 的数据库集群参数组系列名称为 aurora-mysql5.7;Aurora MySQL 1.x 的数据库集群参数组系列名称仍为 aurora5.6

有关完整的 CLI 命令集以及 Aurora MySQL 2.x 和 Aurora MySQL 1.x 之间的差异,请参阅 Aurora 文档。