Amazon Aurora
Aurora 用户指南
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

Aurora MySQL 数据库引擎更新 2019-09-19(版本 2.04.6)

版本:2.04.6

Aurora MySQL 2.04.6 已正式发布。Aurora MySQL 2.x 版与 MySQL 5.7 兼容,Aurora MySQL 1.x 版与 MySQL 5.6 兼容。

您可以选择将现有 Aurora MySQL 2.* 数据库集群升级到 Aurora MySQL 2.04.6。不允许就地升级 Aurora MySQL 1.* 集群。此限制将在稍后的 Aurora MySQL 2.* 版本中解除。您可以将 Aurora MySQL 1.14.*、1.15.*、1.16.*、1.17.*、1.18.*、1.19.*、2.01.*、2.02.*、2.03.* 和 2.04.* 的快照还原到 Aurora MySQL 2.04.6。

要使用 Aurora MySQL 的较旧版本,您可以通过 AWS 管理控制台、AWS CLI 或 Amazon RDS API 指定引擎版本,从而创建新的数据库集群。

如果您有任何问题或疑问,可通过社区论坛和 AWS Premium Support 联系 AWS Support。有关更多信息,请参阅维护 Amazon Aurora 数据库集群

注意

此版本目前在以下 AWS 区域中不可用:欧洲 (伦敦) [eu-west-2]、AWS GovCloud(美国东部) [us-gov-east-1]、AWS GovCloud (US-West) [us-gov-west-1]、中国 (宁夏) [cn-northwest-1] 和 亚太地区(香港) [ap-east-1]。在提供后,将发布单独的公告。

注意

有关如何升级 Aurora MySQL 数据库集群的信息,请参阅 Amazon Aurora MySQL 的数据库升级和修补

改进

  • 修复了以下问题:如果参数 sync_binlog 的值未设定为 1,则主实例上的当前二进制日志文件中的事件不会复制到从实例。

  • 参数 aurora_binlog_replication_max_yield_seconds 的默认值已更改为零,防止复制延迟增加,有利于提高二进制日志主实例的前台查询性能。

集成 MySQL 错误修复

  • 错误#23054591:PURGE BINARY LOGS TO 读取整个二进制日志文件并导致 MySql 停滞

与 Aurora MySQL 版本 1 进行比较

以下 Amazon Aurora MySQL 功能在 Aurora MySQL 版本 1(兼容 MySQL 5.6)中受支持,但这些功能目前在 Aurora MySQL 版本 2(兼容 MySQL 5.7)中不受支持。

MySQL 5.7 兼容性

Aurora MySQL 2.04.6 与 MySQL 5.7 接口兼容并包含一些功能,例如,JSON 支持、空间索引和生成的列。Aurora MySQL 使用采用 z 顺序曲线的空间索引的本机实现,可以为空间数据集提供比 MySQL 5.7 高 20 多倍的写入性能以及高 10 多倍的读取性能。

Aurora MySQL 2.04.6 当前不支持以下 MySQL 5.7 功能:

  • 组复制插件

  • 增加的页面大小

  • InnoDB 缓冲池启动时加载

  • InnoDB 全文分析器插件

  • 多源复制

  • 在线缓冲池大小调整

  • 密码验证插件

  • 查询重写插件

  • 复制筛选

  • CREATE TABLESPACE SQL 语句