Aurora MySQL 数据库引擎更新 2019-11-11(版本 2.05.0) - Amazon Aurora
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

Aurora MySQL 数据库引擎更新 2019-11-11(版本 2.05.0)

版本:2.05.0

Aurora MySQL 2.05.0 已正式发布。Aurora MySQL 2.x 版与 MySQL 5.7 兼容,Aurora MySQL 1.x 版与 MySQL 5.6 兼容。

当前支持的 Aurora MySQL 版本有 1.14.*、1.15.*、1.16.*、1.17.*、1.18.*、1.19.*、2.01.*、2.02.*、2.03.* 和 2.04.*。

您可以将快照从当前支持的 Aurora MySQL 版本还原到 Aurora MySQL 2.05.0。您也可以选择将现有的 Aurora MySQL 2.* 数据库集群(最高 2.04.6)升级到 Aurora MySQL 2.05.0。不能将现有的 Aurora MySQL 1.* 集群直接升级到 2.05.0,但是可以将其快照还原到 Aurora MySQL 2.05.0。

要使用较旧版本的 Aurora MySQL 创建集群,请通过 AWS 管理控制台、AWS CLI 或 RDS API 指定引擎版本。

注意

此版本目前在以下 AWS 区域中不可用:AWS GovCloud(美国东部) [us-gov-east-1]、AWS GovCloud (US-West) [us-gov-west-1]、中国 (宁夏) [cn-northwest-1]、亚太地区(香港) [ap-east-1]、欧洲(斯德哥尔摩) [eu-north-1] 和 中东(巴林) [me-south-1]。在提供后,将发布单独的公告。

如果您有任何问题或疑问,可通过社区论坛和 AWS Premium Support 联系 AWS Support。有关更多信息,请参阅维护 Amazon Aurora 数据库集群

注意

有关如何升级 Aurora MySQL 数据库集群的信息,请参阅 Amazon Aurora MySQL 的数据库升级和修补

改进

关键修复:

高优先级修复:

  • 强烈建议数据库大小接近 64 TiB 的客户升级到此版本,以避免由于稳定性错误影响接近 Aurora 存储限制的卷而导致停机。

  • 参数 aurora_binlog_replication_max_yield_seconds 的默认值已更改为零,防止复制延迟增加,有利于提高二进制日志主实例的前台查询性能。

集成 MySQL 错误修复

  • 错误#23054591:PURGE BINARY LOGS TO 读取整个二进制日志文件并导致 MySql 停滞

与 Aurora MySQL 版本 1 进行比较

以下 Amazon Aurora MySQL 功能在 Aurora MySQL 版本 1(兼容 MySQL 5.6)中受支持,但这些功能目前在 Aurora MySQL 版本 2(兼容 MySQL 5.7)中不受支持。

MySQL 5.7 兼容性

Aurora MySQL 2.05.0 与 MySQL 5.7 接口兼容并包含一些功能,例如,JSON 支持、空间索引和生成的列。Aurora MySQL 使用采用 z 顺序曲线的空间索引的本机实现,可以为空间数据集提供比 MySQL 5.7 高 20 多倍的写入性能以及高 10 多倍的读取性能。

Aurora MySQL 2.05.0 当前不支持以下 MySQL 5.7 功能:

  • 组复制插件

  • 增加的页面大小

  • InnoDB 缓冲池启动时加载

  • InnoDB 全文分析器插件

  • 多源复制

  • 在线缓冲池大小调整

  • 密码验证插件

  • 查询重写插件

  • 复制筛选

  • CREATE TABLESPACE SQL 语句