Aurora MySQL 数据库引擎更新 2020-11-12(版本 2.08.3) - Amazon Aurora
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

Aurora MySQL 数据库引擎更新 2020-11-12(版本 2.08.3)

版本:2.08.3

Aurora MySQL 2.08.3 已正式发布。Aurora MySQL 2.x 版与 MySQL 5.7 兼容,Aurora MySQL 1.x 版与 MySQL 5.6 兼容。

目前支持的可升级到 2.08.3 的 Aurora MySQL 版本有:1.14.*、1.15.*、1.16.*、1.17.*、1.18.*、1.19.*、1.20.*、1.21.*、1.22.*、2.01.*、2.02.*、2.03.*、2.04.*、2.05.*、2.06.*、2.07.* 和 2.08.*。

您现在可以将现有的 Aurora MySQL 2.* 数据库集群直接升级到 Aurora MySQL 2.08.3。您现在可以将现有的 Aurora MySQL 1.* 集群直接升级到 2.07.3 或更高版本,然后直接升级到 2.08.3。

要使用较旧版本的 Aurora MySQL 创建集群,请通过Amazon Web Services Management Console 、Amazon CLI 或 RDS API 指定引擎版本。

如果您有任何问题或疑问,可通过社区论坛和 Amazon Premium Support 联系 Amazon Support。有关更多信息,请参阅“维护 Amazon Aurora 数据库集群”。

注意

有关如何升级 Aurora MySQL 数据库集群的信息,请参阅 升级 Aurora MySQL 数据库集群的次要版本或补丁程序级别

改进

安全修复:

对托管环境中的处理进行微调的修复和其他增强功能。其他 CVE 修复如下:

不兼容的更改:

此版本新增了影响 mysqldump 命令行为的权限更改。用户必须具有访问 PROCESS 表的 INFORMATION_SCHEMA.FILES 权限。要在不进行任何更改的情况下运行 mysqldump 命令,请向 PROCESS 命令连接的数据库用户授予 mysqldump 权限。您也可以运行带 mysqldump 选项的 --no-tablespaces 命令。使用该选项,mysqldump 输出不包含任何 CREATE LOGFILE GROUPCREATE TABLESPACE 语句。在这种情况下,mysqldump 命令不访问 INFORMATION_SCHEMA.FILES 表,您也无需授予 PROCESS 权限。

集成了 MySQL 社区版本错误修复

  • 错误 #23762382 - INSERT VALUES QUERY WITH JOIN IN A SELECT CAUSES INCORRECT BEHAVIOR.

  • 错误 #25209512 - CURRENT_TIMESTAMP PRODUCES ZEROS IN TRIGGER.

与 Aurora MySQL 版本 1 进行比较

以下 Amazon Aurora MySQL 功能在 Aurora MySQL 版本 1(兼容 MySQL 5.6)中受支持,但这些功能目前在 Aurora MySQL 版本 2(兼容 MySQL 5.7)中不受支持。

MySQL 5.7 兼容性

此 Aurora MySQL 版本与 MySQL 5.7 数据兼容,包含 JSON 支持、空间索引及生成列等功能。Aurora MySQL 使用 Z 阶曲线原生实现了空间索引功能,使空间数据集的写入性能相比于 MySQL 5.7 提高了 20 倍以上,读取性能提高 10 倍以上。

此 Aurora MySQL 版本当前不支持以下 MySQL 5.7 功能:

  • 组复制插件

  • 增加的页面大小

  • InnoDB 缓冲池启动时加载

  • InnoDB 全文分析器插件

  • 多源复制

  • 在线缓冲池大小调整

  • 密码验证插件

  • 查询重写插件

  • 复制筛选

  • CREATE TABLESPACE SQL 语句