Aurora PostgreSQL 长期支持(LTS)版本 - Amazon Aurora
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

Aurora PostgreSQL 长期支持(LTS)版本

每个新的 Aurora PostgreSQL 版本在一定时间内保持可用状态,以便在创建或升级数据库集群时使用。在此期间后,您必须升级使用该版本的任何集群。您可以在支持期限结束之前手动升级集群,或者 Aurora 可以在不再支持集群的 Aurora PostgreSQL 版本时自动升级集群。

Aurora 将某些 Aurora PostgreSQL 版本指定为长期支持(LTS)版本。与使用非 LTS 版本的数据库集群相比,使用 LTS 版本的集群可以将同一版本保留更长时间,并经历更短的升级周期。LTS 次要版本仅包含错误修复(通过补丁版本);LTS 版本不包括其推出后发布的新功能。

每年一次,在 LTS 次要版本上运行的数据库集群都会被修补为该 LTS 版本的最新补丁版本。我们进行这种修补,是为了帮助您享受到更高的安全性与稳定性修复。如有关键补丁(例如安全补丁)需要更新,我们可能会更频繁地修补 LTS 次要版本。

注意

要在 LTS 次要版本的生命周期内保留该版本,请确保关闭您数据库实例的自动次要版本升级功能。如需避免您的数据库集群从 LTS 次要版本进行自动升级,请将您 Aurora 集群中所有数据库实例的 Auto minor version upgrade (自动次要版本升级) 设置为 No (否)

对于大多数 Aurora PostgreSQL 集群,我们建议您升级到最新的版本,而不是使用 LTS 版本。这样做可以利用 Aurora 以作为托管服务,并使您可以获取最新的功能和错误修复。LTS 版本适用于具有以下特征的集群:

  • 除了在极少数情况下应用关键补丁以外,您无法承受 Aurora PostgreSQL 应用程序停机带来的损失。

  • 对于 Aurora PostgreSQL 数据库引擎的每次更新,集群和关联的应用程序的测试周期需要很长的时间。

  • Aurora PostgreSQL 集群的数据库版本具有应用程序所需的所有数据库引擎功能和错误修复。

当前针对 Aurora PostgreSQL 的 LTS 版本是 3.4 版本(PostgreSQL 11.9 版本)。该产品于 2020 年 12 月 11 日发布。有关此引擎版本的更多信息,请参阅PostgreSQL 11.9,Aurora PostgreSQL 版本 3.4