Aurora Serverless v1 和 Aurora 数据库引擎版本 - Amazon Aurora
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

Aurora Serverless v1 和 Aurora 数据库引擎版本

Aurora Serverless v1 在某些 Amazon 区域可用,且仅适用于特定 Aurora MySQL 和 Aurora PostgreSQL 版本。有关支持 Aurora Serverless v1 的 Amazon 区域的当前列表,以及每个区域中可用的特定 Aurora MySQL 和 Aurora PostgreSQL 版本,请参阅 Aurora Serverless v1

Aurora Serverless v1 使用其关联 Aurora 数据库引擎来标识每个受支持的数据库引擎的特定受支持版本,如下所示:

  • Aurora MySQL Serverless

  • Aurora PostgreSQL Serverless

当数据库引擎的次要版本对 Aurora Serverless v1 可用时 ,它们将自动应用于 Aurora Serverless v1 可用的各个 Amazon 区域。换句话说,在集群的数据库引擎对 Aurora Serverless v1 可用时,您无需升级 Aurora Serverless v1 数据库集群即可获得新的次要版本。

Aurora MySQL Serverless

如果要将 Aurora MySQL-Compatible Edition 用于 Aurora Serverless v1 数据库集群,可以在 Aurora MySQL 5.6 兼容版本或 Aurora MySQL 5.7 兼容版本之间进行选择。这两个 Aurora MySQL 版本的差异很大。我们建议您在创建 Aurora Serverless v1 数据库集群之前比较它们的差异,以便为使用案例做出正确的选择。要了解 Aurora MySQL Serverless 5.6 和 5.7 的增强功能和错误修复,请参阅 Aurora MySQL Serverless 集群的数据库引擎更新

Aurora PostgreSQL Serverless

如果想要将 Aurora PostgreSQL 用于您的 Aurora Serverless v1 数据库集群,则可以使用单个版本。Aurora PostgreSQL-Compatible Edition 的次要版本仅包括向后兼容的更改。当 Aurora PostgreSQL 次要版本在您的区域变得对 Aurora Serverless v1 可用时,您的 Aurora Serverless v1 数据库集群将以透明方式升级。

例如,次要版本 Aurora PostgreSQL 10.12 版本已透明地应用于运行先前 Aurora PostgreSQL 版本的所有 Aurora Serverless v1 数据库集群。有关 Aurora PostgreSQL 版本 10.12 更新的更多信息,请参阅 PostgreSQL 10.12,Aurora PostgreSQL 版本 2.5