主要版本升级。 - Amazon Relational Database Service
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

主要版本升级。

要执行主要版本升级,请手动修改数据库实例。主要版本升级不会自动进行。

主要版本升级支持的版本

Amazon RDS 支持以下主要版本升级。

当前版本 支持升级

12.2.0.1

19.0.0.0

12.1.0.2

19.0.0.0

12.2.0.1

Oracle 数据库的主要版本升级必须升级到在同一个月或更晚发布的版本更新 (RU)。任何 Oracle 版本都不支持主要版本降级。

主要版本升级支持的实例类

您当前的 Oracle 数据库实例可能在您要升级到的版本不支持的数据库实例类上运行。在这种情况下,在升级之前,请将数据库实例迁移到受支持的数据库实例类。有关 Amazon RDS for Oracle 的每个版本支持的数据库实例类的更多信息,请参阅 数据库实例类

在主要版本升级之前收集统计信息

在执行主要版本升级前,Oracle 建议您对您要升级的数据库实例收集优化器统计数据。此操作可以减少升级过程中的数据库实例停机时间。

要收集优化器统计数据,请以主用户身份连接到数据库实例,然后运行以下 DBMS_STATS.GATHER_DICTIONARY_STATS 过程,如以下示例所示。

EXEC DBMS_STATS.GATHER_DICTIONARY_STATS;

有关更多信息,请参阅 Oracle 文档中的收集优化程序统计数据以减少 Oracle 数据库停机时间

允许主要版本升级

主要引擎版本升级可能与您的应用程序不兼容。升级是不可逆的。如果为 EngineVersion 参数指定的主要版本与当前主要版本不同,则必须允许主要版本升级。

如果使用 CLI 命令 modify-db-instance 升级主要版本,请指定 --allow-major-version-upgrade。由于此设置不具备持久性,因此只要执行主要升级,就必须指定 --allow-major-version-upgrade。此参数对次要引擎版本的升级没有影响。有关更多信息,请参阅“升级数据库实例引擎版本”。

如果您使用控制台升级主要版本,则无需选择允许升级的选项。相反,控制台会显示一条警告,指出主要升级是不可逆的。