安装、更新和卸载 Amazon CLI - Amazon Command Line Interface
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文档仅适用于 Amazon CLI 版本 1。有关 Amazon CLI 版本 2 的相关文档,请参阅版本 2 用户指南

安装、更新和卸载 Amazon CLI

本主题提供用于安装、更新和卸载 Amazon Command Line Interface(Amazon CLI) 原始版本的链接。当前支持 Amazon CLI 版本 1,而添加到 Amazon CLI 版本 2 的新功能无法添加到 Amazon CLI 版本 1。要使用这些功能,您必须安装 Amazon CLI 版本 2。有关如何安装版本 2 的信息,请参阅安装 Amazon CLI 版本 2

Amazon CLI 安装、更新和卸载说明:

Python 版本要求

Amazon CLI 版本 1 使用 SDK for Python 构建,因此需要安装 Python 的兼容版本。

Python 版本支持矩阵
Amazon CLI version 支持的 Python 版本
1.20.0 – 当前 Python 3.6+
1.19.0 — 1.19.x Python 2.7+、Python 3.6+
1.17 – 1.18.x Python 2.7+、Python 3.4+
1.0 – 1.16.x Python 2.6 及更早版本,Python 3.3 及更早版本