AWS Database Migration Service
用户指南 (版本 API Version 2016-01-01)
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

AWS Database Migration Service 的目标

在使用 AWS Database Migration Service 进行数据迁移时,可以将以下数据存储作为目标终端节点。

本地实例数据库和 Amazon EC2 实例数据库

  • Oracle 版本 10g、11g、12c 和 18c(Enterprise、Standard、Standard One 和 Standard Two 版)。

    注意

    AWS DMS 版本 3.3.0 和更高版本中支持将 Oracle 版本 8c 作为目标。

  • Microsoft SQL Server 版本 2005、2008、2008R2、2012、2014 和 2016 (Enterprise、Standard、Workgroup 和 Developer 版)。不支持 Web 和 Express 版。

  • MySQL 版本 5.5、5.6 和 5.7。

  • MariaDB(支持作为 MySQL 兼容数据目标)版本 10.0.24 到 10.0.28、10.1、10.2 和 10.3。

    注意

    在所有支持 MySQL 的 AWS DMS 版本中,均支持 MariaDB 作为目标。

  • PostgreSQL 9.4 和更高版本(对于版本 9.x)、10.x 和 11.x。

    注意

    仅 AWS DMS 版本 3.3.0 和更高版本中支持将 PostgreSQL 版本 11.x 作为目标。在任意 DMS 版本中,您可以使用 PostgreSQL 版本 9.4 及更高版本(对于版本 9.x)和 10.x 作为目标。

  • SAP Adaptive Server Enterprise (ASE) 版本 15、15.5、15.7、16 和更高版本。

Amazon RDS 实例数据库、Amazon Redshift、Amazon DynamoDB、Amazon S3、Amazon Elasticsearch Service、Amazon Kinesis Data Streams 和 Amazon DocumentDB

  • Oracle 版本 11g(版本 11.2.0.3.v1 和更高版本)、12c 和 18c(Enterprise、Standard、Standard One 和 Standard Two 版)。

    注意

    AWS DMS 版本 3.3.0 和更高版本中支持将 Oracle 版本 8c 作为目标。

  • Microsoft SQL Server 版本 2008 R2、2012 和 2014 (Enterprise、Standard、Workgroup 和 Developer 版)。不支持 Web 和 Express 版。

  • MySQL 版本 5.5、5.6 和 5.7。

  • MariaDB(支持作为 MySQL 兼容数据目标)版本 10.0.24 到 10.0.28、10.1、10.2 和 10.3。

    注意

    在所有支持 MySQL 的 AWS DMS 版本中,均支持 MariaDB 作为目标。

  • PostgreSQL 9.4 和更高版本(对于版本 9.x)、10.x 和 11.x。

    注意

    仅 AWS DMS 版本 3.3.0 和更高版本中支持将 PostgreSQL 版本 11.x 作为目标。在任意 DMS 版本中,您可以使用 PostgreSQL 版本 9.4 及更高版本(对于版本 9.x)和 10.x 作为目标。

  • Amazon Aurora 与 MySQL 的兼容性。

  • 与 PostgreSQL 兼容的 Amazon Aurora。

  • Amazon Redshift。

  • Amazon S3。

  • Amazon DynamoDB。

  • Amazon Elasticsearch Service。

  • Amazon Kinesis Data Streams。

  • Amazon DocumentDB(与 MongoDB 兼容)。