CacheEngineVersion - Amazon ElastiCache
Services or capabilities described in Amazon Web Services documentation might vary by Region. To see the differences applicable to the China Regions, see Getting Started with Amazon Web Services in China.

CacheEngineVersion

Provides all of the details about a particular cache engine version.

Contents

Note

In the following list, the required parameters are described first.

CacheEngineDescription

The description of the cache engine.

Type: String

Required: No

CacheEngineVersionDescription

The description of the cache engine version.

Type: String

Required: No

CacheParameterGroupFamily

The name of the cache parameter group family associated with this cache engine.

Valid values are: memcached1.4 | memcached1.5 | memcached1.6 | redis2.6 | redis2.8 | redis3.2 | redis4.0 | redis5.0 | redis6.x

Type: String

Required: No

Engine

The name of the cache engine.

Type: String

Required: No

EngineVersion

The version number of the cache engine.

Type: String

Required: No

See Also

For more information about using this API in one of the language-specific Amazon SDKs, see the following: