Compatibility - Amazon EKS
Services or capabilities described in Amazon Web Services documentation might vary by Region. To see the differences applicable to the China Regions, see Getting Started with Amazon Web Services in China.

Compatibility

Compatibility information.

Contents

clusterVersion

The supported Kubernetes version of the cluster.

Type: String

Required: No

defaultVersion

The supported default version.

Type: Boolean

Required: No

platformVersions

The supported compute platform.

Type: Array of strings

Required: No

See Also

For more information about using this API in one of the language-specific Amazon SDKs, see the following: