AWS Lambda
开发人员指南
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

设置 PowerShell 开发环境

要设置编写 PowerShell 脚本的开发环境,请执行以下操作:

  1. 安装正确的 PowerShell 版本。Lambda 的 PowerShell 支持基于跨平台的 PowerShell Core 6.0 版本。这意味着,您可以在 Windows、Linux 或 Mac 上开发 PowerShell Lambda 函数。如果您未安装此版本的 PowerShell,您可以在安装 PowerShell Core 中查找说明。

  2. 安装 .NET Core 2.1 开发工具包。由于 PowerShell Core 基于 .NET Core,因此,Lambda 的 PowerShell 支持使用相同的 .NET Core 2.1 Lambda 运行时开发 .NET Core 和 PowerShell Lambda 函数。新的 Lambda PowerShell 发布 cmdlet 使用 .NET Core 2.1 开发工具包创建 Lambda 部署程序包。Microsoft 网站上的 .NET 下载提供了 .NET Core 2.1 开发工具包。请务必安装开发工具包,而不是运行时安装。

  3. 安装 AWSLambdaPSCore 模块。您可以从 PowerShell 库安装此模块,也可以通过使用以下 PowerShell Core shell 命令来安装此模块:

    Install-Module AWSLambdaPSCore -Scope CurrentUser

后续步骤

  • 如需了解关于在 PowerShell 中编写 Lambda 函数的更多信息,请参阅 使用 PowerShell 构建 Lambda 函数

  • 如需了解关于使用 AWSLambdaPSCore 模块从模板中下载示例 PowerShell 项目、创建 PowerShell 部署程序包,以及在 AWS 云中部署 PowerShell 函数的更多信息,请参阅 使用 AWSLambdaPSCore 模块

本页内容: