Compatible Apache Kafka Versions - Amazon Managed Streaming for Apache Kafka
Services or capabilities described in Amazon Web Services documentation might vary by Region. To see the differences applicable to the China Regions, see Getting Started with Amazon Web Services in China.

Compatible Apache Kafka Versions

The Apache Kafka versions to which you can update the cluster.

URI

/v1/compatible-kafka-versions

HTTP methods

GET

Operation ID: GetCompatibleKafkaVersions

Returns a list of the Apache Kafka versions to which you can update this cluster.

Query parameters
NameTypeRequiredDescription
clusterArnStringFalse

The Amazon Resource Name (ARN) of the cluster check.

Responses
Status codeResponse modelDescription
200 GetCompatibleKafkaVersionsResponse

200 response

400Error

The request isn't valid because the input is incorrect. Correct your input and then submit it again.

401Error

The request is not authorized. The provided credentials couldn't be validated.

403Error

Access forbidden. Check your credentials and then retry your request.

404Error

The resource could not be found due to incorrect input. Correct the input, then retry the request.

429Error

429 response

500Error

There was an unexpected internal server error. Retrying your request might resolve the issue.

503Error

503 response

OPTIONS

Enable CORS by returning the correct headers.

Responses
Status codeResponse modelDescription
200None

Default response for CORS method

Schemas

Response bodies

{ "compatibleKafkaVersions": [ { "sourceVersion": "string", "targetVersions": [ "string" ] } ] }
{ "message": "string", "invalidParameter": "string" }

Properties

CompatibleKafkaVersion

Contains source Apache Kafka versions and compatible target Apache Kafka versions.

PropertyTypeRequiredDescription
sourceVersion

string

False

An Apache Kafka version.

targetVersions

Array of type string

False

A list of Apache Kafka versions.

Error

Returns information about an error.

PropertyTypeRequiredDescription
invalidParameter

string

False

The parameter that caused the error.

message

string

False

The description of the error.

GetCompatibleKafkaVersionsResponse

Response body for GetCompatibleKafkaVersions.

PropertyTypeRequiredDescription
compatibleKafkaVersions

Array of type CompatibleKafkaVersion

False

A list of CompatibleKafkaVersion objects.