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Atlassian Confluence 云知识库集成 - Amazon Quick
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅 中国的 Amazon Web Services 服务入门 (PDF)

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Atlassian Confluence 云知识库集成

使用 Atlassian Confluence Cloud 知识库集成为 Confluence 内容编制索引,这样 Amazon Quick 代理就可以搜索和回答有关该内容的问题。Amazon Quick 支持 Confluence 知识库的可选文档级访问控制 (ACL)。启用后,用户只能在 Confluence 中看到他们有权访问的文档中的答案。有关更多信息,请参阅 Document-level 访问控制

开始前的准备工作

在设置集成之前,请确保您具备以下条件。

如果您计划启用文档级访问控制,则必须在设置过程中提供 Atlassian 管理员凭据。这些凭证允许 Amazon Quick 访问所有用户和群组信息,无论个人的电子邮件可见性设置如何。如果没有管理员凭据,ACL 选项在创建知识库期间不可用。要提供管理员凭证,您需要 Atlassian 组织管理员提供以下信息:

  • Atlassian 管理员 API 密钥 — 在 Atlassian 管理员门户中生成的字母数字字符串。

  • 组织 ID (UUID)-您的 Atlassian 组织的唯一标识符。登录管理门户后,您可以在浏览器网址中找到此信息:admin.atlassian.com/o/orgId.

  • 目录 ID (UUID)-您的用户目录的唯一标识符。使用 Atlassian 管理工作区 API 检索此值。

有关获取这些证书的详细步骤,请参阅获取 Atlassian 管理员证书

设置知识库集成

安装向导分为三个步骤:身份验证、知识库创建和其他设置。

对您的账户进行身份验证

  1. 在 Amazon Quick 控制台中,选择知识

  2. 在 Kn owle dge 下,选择 Atlassian Confluence Cloud,然后选择添加(加上 “+”)按钮。

  3. 在 “创建 Confluence 知识库” 对话框的 “身份验证方法” 下,从 “名称” 下拉列表中选择一个现有的已连接帐户,或者选择 “添加帐户” 来创建新连接。

  4. 如果您要添加新账户,请填写以下字段:

    • 名称-连接的描述性名称。

    • 描述(可选)-有关连接的注释。

    • Confluence 网址 — 您的 Atlassian 网站的网址(例如,)。https://your-site.atlassian.net

  5. (可选)在 “ACL 管理” 下,选择 “使用 Atlassian 管理员凭据提供 Atlassian 管理员凭据”。选中后,输入以下内容:

    • API 密钥 — Atlassian 管理员 API 密钥。

    • 组织 ID (UUID)-您的 Atlassian 组织 ID。

    • 目录 ID (UUID)-您的 Atlassian 用户目录 ID。

    重要

    在 “其他设置” 中启用文档级访问控制 (ACL) 需要 Atlassian 管理员凭据。如果没有管理员凭据,ACL 选项将被禁用。知识库创建后无法添加管理员凭据。有关获取这些证书的步骤,请参阅获取 Atlassian 管理员证书

  6. 选择下一步

  7. 完成出现的 Confluence 云身份验证弹出窗口。查看请求的权限并选择 “接受” 以授权 Amazon Quick 访问您的 Confluence 内容。

创建知识库

  1. 在 “创建知识库” 下,输入知识库的名称

  2. (可选)输入描述,并附上有关如何使用知识库的注释。

  3. Confluence 网址下,粘贴要包含的 Confluence 空间、博客或页面的网址。在每个 URL 后面选择 “添加”。

    注意

    遵循该结构的网址https://company.atlassian.net/wiki/spaces/space-key/overview被视为页面网址,而不是空格网址。要为整个空间编制索引,请使用不带有/overview(例如https://company.atlassian.net/wiki/spaces/space-key)的空间 URL。

  4. 选择 “下一步:其他设置” 以配置访问控制和索引选项,或者选择 “建” 以使用默认设置创建知识库。

配置其他设置

  1. 要启用文档级访问控制,请选择 “使用 ACL 控制文档访问权限”。仅当您在身份验证方法中提供了 Atlassian 管理员凭据时,此选项才可用。启用后,Amazon Quick 会同步来自 Confluence 的访问控制列表,并在查询时验证每个用户的权限。有关访问控制工作原理的更多信息,请参阅Document-level 访问控制

    如果不启用 ACL,则在知识库级别控制访问权限。任何有权访问知识库的人都可以从其中的所有内容中获得见解。启用 ACL 后,将在文档级别控制访问权限。有权访问知识库的用户只能看到他们有权在 Confluence 中访问的文档中的答案。

    重要

    创建知识库后,无法更改 ACL 管理。如果需要更改此设置,则必须创建新的知识库。

    注意

    如果您未在身份验证方法中提供 Atlassian 管理员凭据,则此选项将被禁用。要启用 ACL,请选择 “返回” 或 “取消向导”,然后使用包含管理员凭据的关联帐户重新启动。

  2. 在 “Multi-media 内容”、“文件大小” 和 “文件模式” 下,根据需要配置以下索引选项:

    • 文档中的视觉内容-为视觉内容(例如文档中嵌入的图像和图表)编制索引。

    • 音频文件-索引音频文件附件。

    • 视频文件-索引视频文件附件。

    • 最大单个文件大小-单个附件的最大文件大小(默认值:50 MB)。

  3. 选择创建

受支持的内容类型

  • Confluence 页面和博客文章

  • 页面和博客文章附件

当您添加 Confluence 空间网址时,Amazon Quick 会抓取该空间内的所有页面和博客文章。有关支持的附件文件类型和大小限制,请参阅文件大小和内容限制

管理知识库

编辑现有知识库

  1. 在 Amazon Quick 控制台中,选择知识库

  2. 从列表中选择你的 Confluence Cloud 知识库。

  3. 选择 “操作” 下的三点图标,然后选择 “编辑知识库”。

  4. 根据需要更新您的配置设置,然后选择 “保存”。

故障排除

要编辑、共享或删除您的集成,请参阅管理现有集成

有关一般知识库疑难解答(包括同步问题和文档丢失),请参阅疑难解答知识库

已屏蔽的 OAuth 应用程序授权

症状:

  • 错误消息:“您的网站管理员必须先为 instance-name .atlassian.net 网站授权此应用程序,然后该应用程序才能访问您的帐户。”

  • 在同意对话框中选择 “接受” 无效。

原因:

您的 Atlassian 站点管理员已屏蔽用户安装的 OAuth 应用程序。启用此设置后,只有站点或组织管理员才能授权新的第三方应用程序。

解决步骤:

使用以下选项之一来解决此问题。

  • 选项 1(推荐):管理员直接授权应用程序

    1. Atlassian 站点管理员导航到 Amazon Quick,然后使用 Confluence Cloud 开始新的知识库设置。

    2. 由于管理员拥有站点级别的权限,因此会出现一个没有错误的干净同意屏幕。

    3. 管理员选择 “接受” 安装应用程序。

    管理员授权该应用程序后,网站上的所有其他用户都可以毫无问题地进行连接。

  • 选项 2:暂时允许用户安装应用程序 — 管理员前往 “应用程序” admin.atlassian.com、“Atlassian 应用程序”,然后选择第三方和 Mar ketplace 应用程序的链接。在 “设置” 下,找到 “用户安装的应用程序”,然后切换到允许用户使用应用程序。用户授权 Amazon Quick 后,将该设置切换回屏蔽用户应用程序。

重要

管理员授权适用于每个 Atlassian 站点,而不是每个组织。如果您的公司有多个站点(例如team-a.atlassian.netteam-b.atlassian.net),则每个站点都需要单独授权。

注意

当用户安装的应用程序处于解锁状态(选项 2)时,网站上的任何用户都可以授权任何 OAuth 应用程序。 Re-enable 用户连接后立即屏蔽。

身份验证弹出窗口失败

症状:

  • 身份验证弹出窗口不会立即出现或关闭。

  • 弹出窗口出现,但无法完成 OAuth 流程。

解决步骤:

  1. 确认您的浏览器允许来自 Amazon Quick 控制台域的弹出窗口。

  2. 确认您的网络可以访问您的 Confluence 云实例。

  3. 尝试使用其他浏览器或清除浏览器缓存。

知识库中缺少内容

症状:

  • 知识库同步已完成,但未对预期内容编制索引。

  • 搜索结果不包括来自特定空间或页面的内容。

  • 整个空间中只有一个文档被编入索引。

解决步骤:

  1. 验证通过身份验证的 Confluence Cloud 用户是否可以访问您在设置期间选择的空间和页面。

  2. 检查所选内容类型是否受支持(页面、博客文章和附件)。

  3. 查看知识库配置中的内容选择,确认包含的空格和页面是否正确。

  4. 检查你的 Confluence 网址是否有后/overview缀。以结尾的 URL /wiki/spaces/space-key/overview 被视为单页网址,而不是完整空格。如果您打算索引整个空间,请使用不带索引的空间 URL/overview(例如,https://company.atlassian.net/wiki/spaces/space-key)。

ACL-related 问题

ACL-enabled 知识库中没有结果

  • 当最终用户在第一次查询时出现提示时,请验证他们是否已登录 Confluence。需要登录才能进行实时权限验证。

  • 验证最终用户是否有权访问其 Confluence 实例中的相关 Confluence 内容。

同步期间跳过了文档

  • 如果同步报告显示状态为 “已跳过” 的项目,请验证身份验证用户是否有权访问知识库中包含的 Confluence 空间和页面。

  • 有关验证文档访问权限的更多信息,请参阅检查文档访问权限(ACL 验证)