适用于 Java 的 AWS 开发工具包
开发人员指南
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

设置AWS SDK for Java 2.0 开发人员预览

本主题介绍如何在您的项目中设置和使用AWS SDK for Java。

先决条件

要使用 AWS SDK for Java,必须拥有:

在您的项目中包含开发工具包

根据您的生成系统或 IDE,使用下列方法之一:

注意

可使用支持 MavenCentral 作为项目源的任何生成系统。但是,我们不会为开发人员预览提供可下载的 zip。

编译开发工具包

您可以使用 Maven 构建AWS SDK for Java。Maven 将一步完成下载所有必需的依赖项、构建开发工具包和安装开发工具包。有关安装说明和更多信息,请参阅 http://maven.apache.org/

编译开发工具包

  1. 打开适用于 Java 的 AWS 开发工具包 2.0 (GitHub)

    注意

    开发工具包的版本 1.0 在适用于 Java 的 AWS 开发工具包 1.x (GitHub) 的 GitHub 中也有提供。

  2. 单击 Clone or download (克隆或下载) 按钮以选择您的下载选项。

  3. 在终端窗口中,导航到下载了开发工具包源文件的目录。

  4. 使用以下命令构建并安装开发工具包(需要 Maven)。

    mvn clean install

    生成的 .jar 文件会构建到 target 目录中。

  5. (可选)使用以下命令构建 API 参考文档。

    mvn javadoc:javadoc

    该文档内置于每个服务的 target/site/apidocs/ 目录中。

安装 Java 开发环境

AWS SDK for Java要求使用 Java SE Development Kit 8.0 或更高版本。可以从 http://www.oracle.com/technetwork/java/javase/downloads/ 下载最新的 Java 软件。

选择 JVM

为了让使用AWS SDK for Java的基于服务器的应用程序获得最佳性能,我们建议您使用 Java 虚拟机 (JVM) 的 64 位版本。此 JVM 仅在服务器模式下运行,即使在运行时指定了 -Client 选项也是如此。