从 .NET Standard 1.3 迁移 - 适用于 .NET 的 AWS 开发工具包
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

从 .NET Standard 1.3 迁移

2019 年 6 月 27 日,Microsoft 终止了对 .NET Core 1.0 和 .NET Core 1.1 版本的支持。在此公告之后, 于 2020 年 12 月 31 AWS 日适用于 .NET 的 AWS 开发工具包终止了对 上的 .NET Standard 1.3 的支持。

AWS 在 适用于 .NET 的 AWS 开发工具包 上继续提供针对 .NET Standard 1.3 的服务更新和安全修复,直到 2020 年 10 月 1 日。在此日期之后,.NET Standard 1.3 目标进入维护模式,这意味着不会发布任何新更新;仅AWS应用了关键错误修复和安全补丁。

2020 年 12 月 31 日, 上对 .NET Standard 1.3 的支持适用于 .NET 的 AWS 开发工具包结束。在此日期之后,不会应用错误修复或安全补丁。使用该目标构建的构件仍可在 NuGet 上下载。

您需要了解的内容

  • 如果您正在运行使用 .NET Framework 的应用程序,则不会受到影响。

  • 如果您正在运行使用 .NET Core 2.0 或更高版本的应用程序,则不会受到影响。

  • 如果您正在运行使用 .NET Core 1.0 或 .NET Core 1.1 的应用程序,请按照 Microsoft 迁移说明将应用程序迁移到 .NET Core 的较新版本。我们建议至少使用 .NET Core 3.1。

  • 如果您正在运行目前无法升级的关键业务应用程序,则可以继续使用当前版本的适用于 .NET 的 AWS 开发工具包。

如果您有疑问或疑虑,请联系 AWS Support