设置环境 - Amazon SDK for .NET
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

是否要将 .NET 应用程序部署到Amazon通过几个简单点击即可? 尝试我们的新.NET CLI 工具为了简化部署体验!阅读我们的博客帖子然后提交反馈GitHub

有关更多信息,请参阅部署工具

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

设置环境

这是适用于预览版中功能的预发行文档。本文档随时可能更改。

以下各节介绍如何设置环境以运行部署工具。

Node.js

部署工具需要Amazon Cloud Development Kit (CDK),以及Amazon CDK需要Node.js版本 10.13.0 或更高版本(不包括 13.0.0 到 13.6.0 版本)。要了解您安装的版本的 Node.js,请在命令提示符处或终端中运行以下命令:

node --version
注意

如果Amazon CDK未安装在您的计算机上,或者如果Amazon CDK早于所需的最低版本 (1.95.2),则部署工具将安装 CDK 的临时和 “私有” 副本,该副本将仅由该工具使用,从而保持计算机的全局配置不变。

相反,需要安装Amazon CDK,请参阅安装Amazon CDK中的Amazon Cloud Development Kit (CDK)开发人员指南

.NET 内核和 .NET 内核

您的应用程序必须从 .NET 核心 3.1 或更高版本(例如 .NET 核心 3.1、.NET 5.0 等)构建。要查看您拥有的版本,请在命令提示符或终端中运行以下命令:

dotnet --version

有关如何安装或更新 .NET 的信息,请参阅。https://dotnet.microsoft.com/.

(可选)码头

如果您计划使用以下方法将应用程序部署到 Amazon Elastic Container Service (Amazon ECS):Amazon Fargate,则必须将 Docker 安装在运行部署工具的位置。有关更多信息,请参阅 。https://docs.docker.com/engine/install/.

(Linux 和 macOS)ZIP CLI)

为部署捆绑包创建 ZIP 包时使用 ZIP CLI。它用于维护 Linux 文件权限。