AWS services or capabilities described in AWS Documentation may vary by region/location. Click Getting Started with Amazon AWS to see specific differences applicable to the China (Beijing) Region.

Module: Aws::IAM

Defined in:
gems/aws-sdk-iam/lib/aws-sdk-iam.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/role.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/user.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/group.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/types.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/client.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/errors.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/waiters.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/resource.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/access_key.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/mfa_device.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/role_policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/user_policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/current_user.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/group_policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/login_profile.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/saml_provider.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/policy_version.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/access_key_pair.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/account_summary.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/instance_profile.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/assume_role_policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/server_certificate.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/virtual_mfa_device.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/signing_certificate.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/account_password_policy.rb,
gems/aws-sdk-iam/lib/aws-sdk-iam/customizations/resource.rb

Overview

WARNING ABOUT GENERATED CODE

This file is generated. See the contributing guide for more information: https://github.com/aws/aws-sdk-ruby/blob/master/CONTRIBUTING.md

WARNING ABOUT GENERATED CODE

Defined Under Namespace

Modules: Errors, Types, Waiters Classes: AccessKey, AccessKeyPair, AccountPasswordPolicy, AccountSummary, AssumeRolePolicy, Client, CurrentUser, Group, GroupPolicy, InstanceProfile, LoginProfile, MfaDevice, Policy, PolicyVersion, Resource, Role, RolePolicy, SamlProvider, ServerCertificate, SigningCertificate, User, UserPolicy, VirtualMfaDevice

service collapse

GEM_VERSION =
'1.46.0'