适用于 SAP ABAP 的 Amazon SDK 发布 - Amazon 适用于 SAP 的 SDK ABA
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅 中国的 Amazon Web Services 服务入门 (PDF)

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

适用于 SAP ABAP 的 Amazon SDK 发布

Amazon 适用于 SAP ABAP 的 SDK 以传输形式交付,适用于 SAP ABAP 的 S Amazon DK-BTP 版本作为附加组件提供。导入传输和附加组件的机制不同,但技术功能相同。有关更多信息,请参阅设置

版本策略

的 适用于 SAP ABAP 的 Amazon SDK 版本 1 经常更新。根据的发布和更新,每周或每天都会发布新补丁 Amazon Web Services。的补丁 Amazon Web Services 可能包括错误修复和其他更新 SDK 补丁级别的更改。有关更多信息,请参阅 Amazon SDK 和工具维护政策

最佳实践

亚马逊建议为所有 SAP 系统(开发、QA 和生产系统)保留适用于 SAP ABAP 的 SDK 的相同补丁级别。

在修补 SDK 时,向沙盒导入最新版本。然后按照常规更改控制程序,向开发、QA 和生产系统导入此版本。

修补适用于 SAP ABAP 的 SDK

适用于 SAP ABAP 的 SDK 的每个版本都是以一套累积传输的形式交付的,其中包括所有错误修复、功能和更新内容。补丁和安装传输是一样的。为修补适用于 SAP ABAP 的 SDK,请务必导入最新传输版本。

鉴于 core 运行时系统与 API 模块的依赖关系,即使您不再使用这些模块,也必须修补 core 模块和其他所有已安装的模块。例如,如果您在安装 SDK 时导入了 coreec2lmd 传输,则必须在修补时导入 coreec2lmd 的最新传输版本。

安装其他模块

将传输版本导入与现有 core 和模块具有相同补丁级别的新模块,从而在 SAP 系统中安装其他 API 模块。如需导入更新版本的模块,请遵循 修补适用于 SAP ABAP 的 SDK 指南。以此确保补丁级别可兼容所有 SDK 模块。

卸载适用于 SAP ABAP 的 SDK

要卸载适用于 SAP ABAP 的 SDK,你必须从 https://sdk-for-sapabap.aws.amazon.comawsSdkSapabap/V1/release/uninstall-abapsdk-LATEST.zip 下载删除传输套件。

curl "https://sdk-for-sapabap.aws.amazon.com/awsSdkSapabapV1/release/uninstall-abapsdk-LATEST.zip" -o "uninstall-abapsdk-LATEST.zip"

你可以从 https://sdk-for-sapabap.aws.amazon.com/ v1/release/uninstall-abapsdk-latest. awsSdkSapabap sig 下载签名文件。如需验证此文件,请参阅验证适用于 SAP ABAP 的 SDK

对于安装在 SAP 系统上的所有 SDK 模块,请务必从上述 ZIP 文件中导入相应的删除传输套件。无需卸载整个 SDK 即可移除单个模块。只要向需移除的模块导入删除传输套件即可。如需卸载整个 SDK 及其所有模块,则必须在最后导入核心删除传输

亚马逊建议您先在沙盒中测试卸载流程,再将其应用于开发、QA 或生产系统。

注意事项

请先阅读以下注意事项再卸载 SDK。

  • 来自的 SDK 配置设置将丢失。必须重新配置 IMG 才能完成安装。

  • SDK 移除后,基于 SDK 运行的 Z 程序会生成语法错误。

  • 移除 SDK 后,包含 SDK 授权参考的 PFCG 或企业角色的授权将无效。请先删除 PFCG 角色中的 SDK 授权参考,再卸载 SDK。

注意

Amazon 开发者预览版期间无法卸载适用于 SAP ABAP 的 SDK-BTP 版本。