Prerequisites - Amazon Kinesis Data Streams
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Prerequisites

以下是完成 教程:使用 KPL 和 KCL 1.x 处理实时股票数据 的要求。

Amazon Web Services 账户

在开始之前,请确保熟悉Amazon Kinesis Data Streams 术语和概念中讨论的概念,特别是流、分片、创建者和使用者。参阅安装和配置 Amazon CLI也很有帮助。

您需要 Amazon 账户和 Web 浏览器才能访问 Amazon Web Services Management Console。

对于控制台访问,请使用 IAM 用户名和密码登录Amazon Web Services Management Console来自 的IAM 登录页面。IAM 使您能够安全地控制对Amazon服务和资源 Amazon Web Services 账户 。有关控制台和编程凭据的详细信息,请参阅了解并获取您的安全凭证中的Amazon一般参考

有关 IAM 和安全密钥设置说明的更多信息,请参阅创建 IAM 用户

系统软件要求

用于运行应用程序的系统必须已安装 Java 7 或更高版本。要下载和安装最新 Java 开发工具包 (JDK),请转到 Oracle 的 Java SE 安装站点

如果您具有 Java IDE(如 Eclipse),则可打开源代码,然后编辑、构建并运行它。

您需要最新的 Amazon SDK for Java 版本。如果您将 Eclipse 用作 IDE,则可以安装AmazonToolkit for Eclipse相反。

使用者应用程序需要 Kinesis L (KCL) 1.2.1 版或更高版本,您可以从上的 GitHub 获得该版本。Kinesis 客户端库 (Java)

后续步骤

第 1 步:创建数据流