支持的操作系统 - Amazon Systems Manager
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

支持的操作系统

您的 Amazon Elastic Compute Cloud (Amazon EC2) 实例、本地服务器和虚拟机 (VM) 必须运行以下操作系统之一,才能将它们与Amazon Systems Manager.

Linux

Amazon Linux
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2012.03 – 2018.03
注意

从版本 2015.03 开始,亚马逊 Linux 在Intel 64-bit (x86_64)版本。

Amazon Linux 2
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2.0 和所有更高版本
CentOS
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
6.x¹
7.1 及更高的 7.x 版本
8.0、8.1 和 8.2 版本

¹ SSM Agent不再正式支持这些版本,也不再为这些版本的 CentOS 更新代理。SSM AgentCentOS 6 支持 3.0.1390.0 及更早版本的版本。

Debian 服务器
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
Jessie(8)
Stretch(9)
Buster(10)
Oracle Linux
版本 Intel 32 位 (x86) Intel 64 位 (x86_64) ARM 64 位 (arm64)
7.5
7.6
7.7
7.8
8.1
8.2
8.3
Red Hat Enterprise Linux (RHEL)
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
6.x¹
7.0
7.1
7.2
7.3
7.4
7.5
7.6
7.7
7.8
7.9
8.0
8.1
8.2
8.3

¹ SSM Agent不再正式支持这些版本,并且不再更新这些版本的RHEL.SSM Agent版本 3.0.1390.0 及更早版本的RHEL6.

SUSE Linux Enterprise Server (SLES)
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
12 及更高的 12.x 版本
15 及更高的 15.x 版本
Ubuntu Server
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
12.04 LTS 和 14.04 LTS
16.04 LTS 和 18.04 LTS
20.04 LTS 和 20.10 STR

macOS

Version Intel 32 位 (x86) Intel 64 位 (x86_64) ARM 64 位 (arm64)
10.14.x (莫哈韦)
10.15.x (卡塔利娜)
11.x (比格苏尔)
注意

macOS支持仅限于以下 Amazon Web Services 区域 :

  • • 美国东部(弗吉尼亚北部)(us-east-1)

  • • 美国东部(俄亥俄)(us-east-2)

  • • 美国西部(俄勒冈)(us-west-2)

  • 欧洲(爱尔兰)(eu-west-1)

  • • 亚太地区(新加坡)(ap-southeast-1)

有关 Amazon EC2 支持的更多信息macOS,请参阅Amazon EC2Mac 实例中的适用于 Linux 实例的 Amazon EC2 用户指南

树莓派 OS(原覆盆子)

Version ARM 32-bit (arm)
8 (Jessie)
9 (Stretch)

相关内容

管理覆盆子派设备使用 Amazon Systems Manager

Windows Server

SSM Agent需要Windows PowerShell 3.0或更高版本运行某些Amazon Systems Manager文档(SSM 文档)Windows Server实例(例如,传统的AWS-ApplyPatchBaseline文档)。验证您的Windows Server实例正在运行Windows Management Framework 3.0或更高版本. 此框架包括Windows PowerShell. 有关更多信息,请参阅Windows Management Framework 3.0

Version Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2008¹
2008 R2¹
2012 和 2012 R2
2016
2019
重要

这些区域有:SSM Agent需要Windows PowerShell 3.0或更高版本来运行某些 SSM 文档Windows Server实例(例如,传统的AWS-ApplyPatchBaseline文档)。验证您的Windows Server实例正在运行Windows Management Framework 3.0或更高版本. 此框架包括Windows PowerShell. 有关更多信息,请参阅Windows Management Framework 3.0

¹截至 2020 年 1 月 14 日,Windows Server2008不再受支持以获取来自微软的功能或安全更新。传统Amazon Machine Images(AMIs) 用于Windows Server2008 年和 2008 年 R2 仍然包含SSM Agent预安装,但 Systems Manager 不再正式支持 2008 年版本,并且不再更新这些版本的Windows Server. 此外,SSM Agent 版本 3.0可能不会兼容上的所有操作Windows Server2008 和 2008 R2。官方支持的最终版本SSM Agent对于 来说为Windows Server2008 年版本为 2.3.1644.0。