有关软件更新的提示 - 深度学习 AMI
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

有关软件更新的提示

有时,您可能想要在 DLAMI 上手动更新软件。通常建议您使用 pip 来更新 Python 软件包。您还应使用pip在使用 Conda 的深度学习 AMI 上的 Conda 环境内的软件包。有关升级和安装说明,请参阅特定框架或软件的网站。

注意

我们无法保证软件包更新会成功。尝试在具有不兼容依赖关系的环境中更新软件包可能会导致失败。在这种情况下,你应该联系库维护者,看看是否可以更新软件包依赖关系。或者,您可以尝试以允许更新的方式修改环境。但是,这种修改可能意味着删除或更新现有软件包,这意味着我们无法再保证此环境的稳定性。

如果您有兴趣运行某个特定软件包的最新主分支,请激活相应的环境,然后添加--pre到最后pip install --upgrade命令。例如:

source activate mxnet_p36 pip install --upgrade mxnet --pre

这些区域有:Amazon Deep Learning AMI随附了许多 Conda 环境和许多预安装的软件包。由于预安装的软件包的数量,很难找到一组保证兼容的软件包。你可能会看到警告“环境不一致,请仔细检查套餐计划”. DLAMI 确保所有 DLAMI 提供的环境都是正确的,但不能保证任何用户安装的软件包都能正常运行。