AWS Database Migration Service
用户指南 (版本 API Version 2016-01-01)
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

数据迁移的源

AWS Database Migration Service (AWS DMS) 可以将很多最常用的数据引擎作为数据复制源。数据库源可以是在 Amazon Elastic Compute Cloud (Amazon EC2) 实例上运行的自管理引擎,也可以是本地数据库。或者,它也可以是 Amazon 托管服务(如 Amazon Relational Database Service (Amazon RDS) 或 Amazon Simple Storage Service)上的数据源。

AWS DMS 的有效源包括:

本地和 Amazon EC2 实例数据库

  • Oracle 10.2 和更高版本、11g 直至 12.2 版本 (Enterprise、Standard、Standard One 和 Standard Two 版)。

  • Microsoft SQL Server 版本 2005、2008、2008R2、2012、2014 和 2016 (Enterprise、Standard、Workgroup 和 Developer 版)。不支持 Web 和 Express 版本。

  • MySQL 版本 5.5、5.6 和 5.7。

  • MariaDB (作为与 MySQL 兼容的数据源受支持)。

  • PostgreSQL 9.4 及更高版本。

  • SAP Adaptive Server Enterprise (ASE) 版本 12.5.3 或更高版本、15、15.5、15.7、16 和更高版本。

  • MongoDB 版本 2.6.x 和 3.x 和更高版本.

  • Db2 LUW 版本:

    • 9.7 版,所有修复包都受支持。

    • 10.1 版,所有修复包都受支持。

    • 10.5 版,除修复包 5 之外的所有修复包都受支持。

Microsoft Azure

  • 将 Azure SQL 数据库作为源时,AWS DMS 支持完全数据加载。不支持更改数据捕获 (CDC)。

Amazon RDS 实例数据库

  • Oracle 版本 11g (版本 11.2.0.3.v1 和更高版本) 和 12c,包括 Enterprise、Standard、Standard One 和 Standard Two 版.

  • Microsoft SQL Server 版本 2008R2、2012、2014 和 2016,包括 Enterprise 和 Standard 版。对于 Enterprise Edition,所有版本都支持 CDC。对于 Standard Edition,只有版本 2016 SP1 和更高版本支持 CDC。AWS DMS 不支持 Web、Workgroup、Developer 和 Express 版本。

  • MySQL 版本 5.5、5.6 和 5.7。只有版本 5.6 和更高版本支持更改数据捕获 (CDC)。

  • PostgreSQL 9.4 和更高版本。只有版本 9.4.9 和更高版本以及 9.5.4 和更高版本支持 CDC。只有这些版本及更高版本才支持 CDC 必需的 rds.logical_replication 参数。

  • MariaDB (作为与 MySQL 兼容的数据源受支持)。

  • Amazon Aurora 与 MySQL 的兼容性。

  • 与 PostgreSQL 兼容的 Amazon Aurora.

Amazon Simple Storage Service

  • 将 Amazon Simple Storage Service 作为源时,AWS DMS 支持完全数据加载和更改数据捕获 (CDC)。