备选的兼容 CNI 插件 - Amazon EKS
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

备选的兼容 CNI 插件

Amazon EKS 仅官方支持 Amazon VPC CNI plugin for Kubernetes。Amazon EKS 运行上游 Kubernetes 且经认证符合 Kubernetes 要求,但是,您可以将备用 CNI 插件安装到集群中的 Amazon EC2 节点。如果您的集群中有 Fargate 节点,则您的集群无法将备用 CNI 插件安装到 Fargate 节点。适用于 Amazon EKS 的 Amazon VPC CNI 插件已在您的 Fargate 节点上,但它是唯一可以与 Fargate 节点一起使用的插件。如果您计划在生产中使用备选 CNI 插件,那么我们强烈建议要么您获得商业支持,要么拥有内部专业知识来排查开源 CNI 插件项目的问题并提供修复。

Amazon EKS 与为备选的兼容 CNI 插件提供支持的合作伙伴网络保持着合作关系。请参阅以下合作伙伴的文档,了解受支持的 Kubernetes 版本以及获得的资格和所执行的测试的详细信息。

合作伙伴

产品

文档

Tigera

Calico

安装说明

Isovalent

Cilium

安装说明

Weaveworks

Weave Net

安装说明

VMware

Antrea

安装说明

Amazon EKS 旨在为您提供广泛的选项来涵盖所有使用案例。如果您开发的商业上支持的 Kubernetes CNI 插件未在此处列出,请通过 aws-container-partners@amazon.com 与我们的合作伙伴团队联系以获取更多信息。