AWS Elastic Beanstalk
平台
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

Java SE 平台历史记录

此页列出了早期版本的 AWS Elastic Beanstalk 的 Java 平台以及每个版本成为当前版本的日期。您在过去 30 天内用于启动或更新环境的平台版本即使在它们不再是最新版本之后也可用 (对于在已使用的区域中的正在使用的账户而言)。

有关 Elastic Beanstalk 支持的每个平台的最新版本的信息,请参阅支持的平台页面。Detailed release notes are available for recent releases at AWS Elastic Beanstalk 发布说明.

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 12 月 17 日至 2019 年 1 月 22 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.8

64bit Amazon Linux 2018.03 v2.7.8 running Java 8

2018.03.0

Java 1.8.0_191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.8

64bit Amazon Linux 2018.03 v2.7.8 running Java 7

2018.03.0

Java 1.7.0.191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 11 月 16 日至 2018 年 12 月 16 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.7

64bit Amazon Linux 2018.03 v2.7.7 running Java 8

2018.03.0

Java 1.8.0_191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.7

64bit Amazon Linux 2018.03 v2.7.7 running Java 7

2018.03.0

Java 1.7.0.191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 10 月 29 日至 2018 年 11 月 15 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.6

64bit Amazon Linux 2018.03 v2.7.6 running Java 8

2018.03.0

Java 1.8.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.6

64bit Amazon Linux 2018.03 v2.7.6 running Java 7

2018.03.0

Java 1.7.0.191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 9 月 25 日至 2018 年 10 月 28 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.5

64bit Amazon Linux 2018.03 v2.7.5 running Java 8

2018.03.0

Java 1.8.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.5

64bit Amazon Linux 2018.03 v2.7.5 running Java 7

2018.03.0

Java 1.7.0.191

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 8 月 20 日至 2018 年 9 月 24 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.4

64bit Amazon Linux 2018.03 v2.7.4 running Java 8

2018.03.0

Java 1.8.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.4

64bit Amazon Linux 2018.03 v2.7.4 running Java 7

2018.03.0

Java 1.7.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 8 月 15 日至 2018 年 8 月 19 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.3

64bit Amazon Linux 2018.03 v2.7.3 running Java 8

2018.03.0

Java 1.8.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.3

64bit Amazon Linux 2018.03 v2.7.3 running Java 7

2018.03.0

Java 1.7.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 6 月 21 日至 2018 年 8 月 14 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.2

64bit Amazon Linux 2018.03 v2.7.2 running Java 8

2018.03.0

Java 1.8.0_171

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.2

64bit Amazon Linux 2018.03 v2.7.2 running Java 7

2018.03.0

Java 1.7.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 5 月 15 日至 2018 年 6 月 20 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.7.1

64bit Amazon Linux 2018.03 v2.7.1 running Java 8

2018.03.0

Java 1.8.0_171

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.7.1

64bit Amazon Linux 2018.03 v2.7.1 running Java 7

2018.03.0

Java 1.7.0_181

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 4 月 2 日至 2018 年 5 月 14 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.8

64bit Amazon Linux 2017.09 v2.6.8 running Java 8

2017.09.1

Java 1.8.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.8

64bit Amazon Linux 2017.09 v2.6.8 running Java 7

2017.09.1

Java 1.7.0_171

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 2 月 22 日至 2018 年 4 月 1 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.6

64bit Amazon Linux 2017.09 v2.6.6 running Java 8

2017.09.1

Java 1.8.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.6

64bit Amazon Linux 2017.09 v2.6.6 running Java 7

2017.09.1

Java 1.7.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 1 月 31 日至 2018 年 2 月 21 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.5

64bit Amazon Linux 2017.09 v2.6.5 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.5

64bit Amazon Linux 2017.09 v2.6.5 running Java 7

2017.09.1

Java 1.7.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 1 月 19 日至 2018 年 1 月 30 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.4

64bit Amazon Linux 2017.09 v2.6.4 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.4

64bit Amazon Linux 2017.09 v2.6.4 running Java 7

2017.09.1

Java 1.7.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 1 月 10 日至 2018 年 1 月 18 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.3

64bit Amazon Linux 2017.09 v2.6.3 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.3

64bit Amazon Linux 2017.09 v2.6.3 running Java 7

2017.09.1

Java 1.7.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 1 月 6 日至 2018 年 1 月 9 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.2

64bit Amazon Linux 2017.09 v2.6.2 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.2

64bit Amazon Linux 2017.09 v2.6.2 running Java 7

2017.09.1

Java 1.7.0_161

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 12 月 20 日至 2018 年 1 月 5 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.1

64bit Amazon Linux 2017.09 v2.6.1 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.1

64bit Amazon Linux 2017.09 v2.6.1 running Java 7

2017.09.1

Java 1.7.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 11 月 14 日至 2017 年 12 月 19 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.6.0

64bit Amazon Linux 2017.09 v2.6.0 running Java 8

2017.09.1

Java 1.8.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.6.0

64bit Amazon Linux 2017.09 v2.6.0 running Java 7

2017.09.1

Java 1.7.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 9 月 25 日至 2017 年 11 月 13 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.5.5

64bit Amazon Linux 2017.03 v2.5.5 running Java 8

2017.03.1

Java 1.8.0_141

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java 7 版本 2.5.5

64bit Amazon Linux 2017.03 v2.5.5 running Java 7

2017.03.1

Java 1.7.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.12.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 8 月 30 日至 2017 年 9 月 24 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.5.4

64bit Amazon Linux 2017.03 v2.5.4 running Java 8

2017.03.1

Java 1.8.0_141

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java 7 版本 2.5.4

64bit Amazon Linux 2017.03 v2.5.4 running Java 7

2017.03.1

Java 1.7.0_151

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 8 月 11 日至 2017 年 8 月 29 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X‑Ray

代理服务器

Java 8 版本 2.5.3

64bit Amazon Linux 2017.03 v2.5.3 running Java 8

2017.03.1

Java 1.8.0_141

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java 7 版本 2.5.3

64bit Amazon Linux 2017.03 v2.5.3 running Java 7

2017.03.1

Java 1.7.0_141

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 7 月 20 日至 2017 年 8 月 10 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X-Ray

代理服务器

Java 8 版本 2.5.2

64bit Amazon Linux 2017.03 v2.5.2 running Java 8

2017.03.1

Java 1.8.0_131

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java 7 版本 2.5.2

64bit Amazon Linux 2017.03 v2.5.2 running Java 7

2017.03.1

Java 1.7.0_141

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.3

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 6 月 27 日至 2017 年 7 月 19 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X-Ray

代理服务器

Java 8 版本 2.5.1

64bit Amazon Linux 2017.03 v2.5.1 running Java 8

2017.03.0

Java 1.8.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.2

Java 7 版本 2.5.1

64bit Amazon Linux 2017.03 v2.5.1 running Java 7

2017.03.0

Java 1.7.0_131

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.2

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 5 月 19 日至 2017 年 6 月 26 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X-Ray

代理服务器

Java 8 版本 2.5.0

64bit Amazon Linux 2017.03 v2.5.0 running Java 8

2017.03.0

Java 1.8.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.2

Java 7 版本 2.5.0

64bit Amazon Linux 2017.03 v2.5.0 running Java 7

2017.03.0

Java 1.7.0_131

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

2.0.0

nginx 1.10.2

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 4 月 5 日至 2017 年 5 月 18 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X-Ray

代理服务器

Java 8 版本 2.4.4

64bit Amazon Linux 2016.09 v2.4.4 running Java 8

2016.09.0

Java 1.8.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

1.0.0

nginx 1.10.1

Java 7 版本 2.4.4

64bit Amazon Linux 2016.09 v2.4.4 running Java 7

2016.09.0

Java 1.7.0_131

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

1.0.0

nginx 1.10.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 3 月 8 日至 2017 年 4 月 4 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

AWS X-Ray

代理服务器

Java 8 版本 2.4.3

64bit Amazon Linux 2016.09 v2.4.3 running Java 8

2016.09.0

Java 1.8.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

1.0.0

nginx 1.10.1

Java 7 版本 2.4.3

64bit Amazon Linux 2016.09 v2.4.3 running Java 7

2016.09.0

Java 1.7.0_131

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

1.0.0

nginx 1.10.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2017 年 1 月 28 日至 2017 年 3 月 7 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

AWS X-Ray

Java 8 版本 2.4.1

64bit Amazon Linux 2016.09 v2.4.1 running Java 8

2016.09.0

Java 1.8.0_111

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

1.0.0

Java 7 版本 2.4.1

64bit Amazon Linux 2016.09 v2.4.1 running Java 7

2016.09.0

Java 1.7.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

1.1.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 12 月 22 日至 2017 年 1 月 27 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

AWS X-Ray

Java 8 版本 2.4.0

64bit Amazon Linux 2016.09 v2.4.0 running Java 8

2016.09.0

Java 1.8.0_111

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

1.0.0

Java 7 版本 2.4.0

64bit Amazon Linux 2016.09 v2.4.0 running Java 7

2016.09.0

Java 1.7.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

1.1.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 12 月 9 日至 2016 年 12 月 21 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.3.0

64bit Amazon Linux 2016.09 v2.3.0 running Java 8

2016.09.0

Java 1.8.0_101

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

Java 7 版本 2.3.0

64bit Amazon Linux 2016.09 v2.3.0 running Java 7

2016.09.0

Java 1.7.0_121

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 10 月 28 日至 2016 年 12 月 8 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.2.0

64bit Amazon Linux 2016.09 v2.2.0 running Java 8

2016.09.0

Java 1.8.0_101

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

Java 7 版本 2.2.0

64bit Amazon Linux 2016.09 v2.2.0 running Java 7

2016.09.0

Java 1.7.0_111

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.10.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 8 月 24 日至 2016 年 10 月 27 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.1.6

64bit Amazon Linux 2016.03 v2.1.6 running Java 8

2016.03.3

Java 1.8.0_101

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java 7 版本 2.1.6

64bit Amazon Linux 2016.03 v2.1.6 running Java 7

2016.03.3

Java 1.7.0_111

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 6 月 26 日至 2016 年 8 月 24 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.1.3

64bit Amazon Linux 2016.03 v2.1.3 running Java 8

2016.03.2

Java 1.8.0_91

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java 7 版本 2.1.3

64bit Amazon Linux 2016.03 v2.1.3 running Java 7

2016.03.2

Java 1.7.0_101

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 5 月 6 日至 2016 年 6 月 26 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.1.1

64bit Amazon Linux 2016.03 v2.1.1 running Java 8

2016.03

Java 1.8.0_91

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java 7 版本 2.1.1

64bit Amazon Linux 2016.03 v2.1.1 running Java 7

2016.03

Java 1.7.0_101

Ant 1.9.6、Gradle 2.7、Maven 3.3.3

nginx 1.8.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2018 年 4 月 7 日至 2016 年 5 月 6 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

代理服务器

Java 8 版本 2.1.0

运行 Java 8 的 64 位 Amazon Linux 2016.03 v2.1.0

2016.03

Java 1.8.0_71

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.1

Java 7 版本 2.1.0

运行 Java 7 的 64 位 Amazon Linux 2016.03 v2.1.0

2016.03

Java 1.7.0_95

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.1

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 2 月 26 日至 2016 年 4 月 7 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

Web 服务器

Java 8 版本 2.0.8

运行 Java 8 的 64 位 Amazon Linux 2015.09 v2.0.8

2015.09

Java 1.8.0_71

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java 7 版本 2.0.8

运行 Java 7 的 64 位 Amazon Linux 2015.09 v2.0.8

2015.09

Java 1.7.0_95

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 2 月 11 日至 2016 年 2 月 26 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

Web 服务器

Java 8 版本 2.0.7

运行 Java 8 的 64 位 Amazon Linux 2015.09 v2.0.7

2015.09

Java 1.8.0_65

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java 7 版本 2.0.7

运行 Java 7 的 64 位 Amazon Linux 2015.09 v2.0.7

2015.09

Java 1.7.0_91

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2016 年 1 月 11 日至 2016 年 2 月 11 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

Web 服务器

Java 8 版本 2.0.6

运行 Java 8 的 64 位 Amazon Linux 2015.09 v2.0.6

2015.09

Java 1.8.0_65

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java 7 版本 2.0.6

运行 Java 7 的 64 位 Amazon Linux 2015.09 v2.0.6

2015.09

Java 1.7.0_91

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2015 年 11 月 3 日至 2016 年 1 月 11 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

Web 服务器

Java 8 版本 2.0.4

运行 Java 8 的 64 位 Amazon Linux 2015.09 v2.0.4

2015.09

Java 1.8.0_65

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java 7 版本 2.0.4

运行 Java 7 的 64 位 Amazon Linux 2015.09 v2.0.4

2015.09

Java 1.7.0_91

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.8.0

Java SE 的以下 Elastic Beanstalk 平台版本是 2015 年 9 月 28 日至 2015 年 11 月 3 日之间有效的版本:

平台版本和解决方案堆栈名称

AMI

语言

工具

Web 服务器

Java 8 版本 2.0.2

运行 Java 8 的 64 位 Amazon Linux 2015.03 v2.0.2

2015.03

Java 1.8.0_51

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.6.2

Java 7 版本 2.0.2

运行 Java 7 的 64 位 Amazon Linux 2015.03 v2.0.2

2015.03

Java 1.7.0_85

Ant 1.9.6

Gradle 2.7

Maven 3.3.3

nginx 1.6.2