AWS Elastic Beanstalk
平台
AWS 文档中描述的 AWS 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 AWS 服务入门

计划停用的 AWS Elastic Beanstalk 平台版本

Elastic Beanstalk 提供的预配置平台支持运行为特定编程语言、框架和 Web 容器开发的 Web 应用程序。Elastic Beanstalk 为每个平台提供一种或多种平台版本。有关当前支持的平台版本的更多信息,请参阅AWS Elastic Beanstalk 支持的平台

此页面列出了 Elastic Beanstalk 已计划停用的平台版本,因为它们的一些组件的生命周期即将结束 (EOL)。这些平台版本将仍然可用,直到其即将停用的组件到达公布的停用日期。有关组件停用日期的列表,请参阅 AWS Elastic Beanstalk 开发人员指南 中的 AWS Elastic Beanstalk 平台支持政策

以下各节提供了有关当前支持的所有平台版本的信息。所有基于 Linux 的当前平台版本都在 Amazon Linux 2018.03(64 位) 上运行。

使用 Tomcat 的 Java

Elastic Beanstalk 已计划停用以下使用 Tomcat 的 Java 平台版本。

平台版本和解决方案堆栈名称

AMI

语言

AWS X‑Ray

应用程序服务器

代理服务器

结束日期

Java 8 with Tomcat 8 3.2.2 版

64bit Amazon Linux 2018.03 v3.2.2 running Tomcat 8 Java 8

2018.03.0

Java 1.8.0_222

3.1.0

Tomcat 8.0.53

Apache 2.4.39(默认)、Apache 2.2.34、Nginx 1.14.1

2020-03-01

Java 6 with Tomcat 7 3.2.2 版

64bit Amazon Linux 2018.03 v3.2.2 running Tomcat 7 Java 6

2018.03.0

Java 1.6.0_41

3.1.0

Tomcat 7.0.94

Apache 2.4.39(默认)、Apache 2.2.34、Nginx 1.14.1

2020-03-01

有关当前平台版本的信息,请参阅Java with Tomcat

使用 IIS 的 Windows Server 上的 .NET

Elastic Beanstalk 已计划停用以下 .NET 平台版本。

配置基础知识

平台版本

解决方案堆栈名称

框架

代理服务器

结束日期

Windows Server 2008 R2 with IIS 7.5 1.2.0 版

64bit Windows Server 2008 R2 v1.2.0 running IIS 7.5

.NET Core 2.1.11,支持 2.1.11、2.0.9、1.1.14、1.0.16

.NET Framework 4.8,支持 4.x、2.0、1.x

IIS 7.5

2019-10-16

Windows Server 2008 R2 with IIS 7.5

64bit Windows Server 2008 R2 running IIS 7.5

.NET Framework 4.8,支持 4.x、2.0、1.x

IIS 7.5

2019-10-16

更多详情

平台版本

AMI 版本

适用于 .NET 的 AWS 开发工具包

EC2Config

SSM 代理

Web 部署

AWS X‑Ray

Windows Server 2008 R2 with IIS 7.5 1.2.0 版

2019.09.11

3.15.826

4.9.3519

2.3.634.0

3.6

3.1.0

Windows Server 2008 R2 with IIS 7.5

2019.09.11

3.15.826

4.9.3519

2.3.634.0

3.6

3.1.0

有关当前平台版本的信息,请参阅Windows Server with IIS 上的 .NET

PHP

Elastic Beanstalk 已计划停用以下 PHP 平台版本。

平台版本和解决方案堆栈名称

AMI

语言

Composer

代理服务器

结束日期

PHP 7.1 2.8.15 版

64bit Amazon Linux 2018.03 v2.8.15 running PHP 7.1

2018.03.0

PHP 7.1.30

1.4.2

Apache 2.4.39

2020-03-01

PHP 7.0 2.8.15 版

64bit Amazon Linux 2018.03 v2.8.15 running PHP 7.0

2018.03.0

PHP 7.0.33

1.4.2

Apache 2.4.39

2020-03-01

PHP 5.6 2.8.15 版

64bit Amazon Linux 2018.03 v2.8.15 running PHP 5.6

2018.03.0

PHP 5.6.40

1.4.2

Apache 2.4.39

2020-03-01

PHP 5.5 2.8.15 版

64bit Amazon Linux 2018.03 v2.8.15 running PHP 5.5

2018.03.0

PHP 5.5.38

1.4.2

Apache 2.4.39

2020-03-01

PHP 5.4 2.8.15 版

64bit Amazon Linux 2018.03 v2.8.15 running PHP 5.4

2018.03.0

PHP 5.4.45

1.4.2

Apache 2.4.39

2020-03-01

有关当前平台版本的信息,请参阅PHP

Python

Elastic Beanstalk 已计划停用以下 Python 平台版本。

平台版本和解决方案堆栈名称

AMI

语言

包管理器

包装程序

meld3

AWS X‑Ray

代理服务器

结束日期

Python 3.4 2.9.2 版

64bit Amazon Linux 2018.03 v2.9.2 running Python 3.4

2018.03.0

Python 3.4.10

pip 9.0.3

setuptools 28.8.0

meld3 1.0.2

3.1.0

带有 mod_wsgi 3.5 的 Apache 2.4.39

2020-03-01

Python 2.7 2.9.2 版

64bit Amazon Linux 2018.03 v2.9.2 running Python 2.7

2018.03.0

Python 2.7.16

pip 9.0.3

setuptools 28.8.0

meld3 1.0.2

3.1.0

带有 mod_wsgi 3.5 的 Apache 2.4.39

2020-03-01

Python 2.6 2.9.2 版

64bit Amazon Linux 2018.03 v2.9.2 running Python 2.6

2018.03.0

Python 2.6.9

pip 9.0.3

setuptools 28.8.0

meld3 1.0.2

3.1.0

带有 mod_wsgi 3.5 的 Apache 2.4.39

2020-03-01

有关当前平台版本的信息,请参阅Python

Ruby

Elastic Beanstalk 已计划停用以下 Ruby 平台版本。

平台版本和解决方案堆栈名称

AMI

语言

包管理器

应用程序服务器

AWS X‑Ray

代理服务器

结束日期

Ruby 2.3 with Puma 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.3 with Passenger 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.2 with Puma 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.2 with Passenger 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.1 with Puma 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.1 with Passenger 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.0 with Puma 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

2020-03-01

Ruby 2.0 with Passenger 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

2020-03-01

Ruby 1.9 with Passenger 2.10.2 版

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

2020-03-01

有关当前平台版本的信息,请参阅Ruby