Aurora MySQL database engine updates 2021-11-18 (version 3.01.0, compatible with MySQL 8.0.23) - Amazon Aurora
Services or capabilities described in Amazon Web Services documentation might vary by Region. To see the differences applicable to the China Regions, see Getting Started with Amazon Web Services in China.

Aurora MySQL database engine updates 2021-11-18 (version 3.01.0, compatible with MySQL 8.0.23)

Version: 3.01.0

Aurora MySQL 3.01.0 is generally available. Aurora MySQL 3.01 versions are compatible with MySQL 8.0.23, Aurora MySQL 2.x versions are compatible with MySQL 5.7, and Aurora MySQL 1.x versions are compatible with MySQL 5.6.

For details of new features in Aurora MySQL version 3 and differences between Aurora MySQL version 3 and Aurora MySQL version 2 or community MySQL 8.0, see Comparison of Aurora MySQL version 2 and Aurora MySQL version 3 in the Amazon Aurora User Guide.

Currently supported Aurora MySQL releases are 1.19.5, 1.19.6, 1.22.*, 1.23.*, 2.04.*, 2.07.*, 2.08.*, 2.09.*, 2.10.*, 3.01.* and 3.02.*.

You can restore a snapshot from any currently supported Aurora MySQL version 2 cluster into Aurora MySQL 3.01.0.

For information on planning an upgrade to Aurora MySQL version 3, see Upgrade planning for Aurora MySQL version 3 in the Amazon Aurora User Guide. For the upgrade procedure itself, see Upgrading to Aurora MySQL version 3 in the Amazon Aurora User Guide. For general information about Aurora MySQL upgrades, see Upgrading Amazon Aurora MySQL DB clusters in the Amazon Aurora User Guide.

To create a cluster with an older version of Aurora MySQL, specify the engine version through the Amazon Web Services Management Console, the Amazon CLI, or the Amazon RDS API.

For troubleshooting information, see Troubleshooting upgrade issues with Aurora MySQL version 3.

If you have any questions or concerns, Amazon Support is available on the community forums and through Amazon Support. For more information, see Maintaining an Amazon Aurora DB cluster in the Amazon Aurora User Guide.

Improvements

Aurora MySQL version 3.01.0 is generally compatible with community MySQL 8.0.23. This version includes the security fixes for Common Vulnerabilities and Exposures (CVE) issues as of community MySQL 8.0.23.

Aurora MySQL version 3.01.0 contains all the Aurora-specific bug fixes through Aurora MySQL version 2.10.0.

For details of new features in Aurora MySQL version 3, see Features from community MySQL 8.0 and New parallel query optimizations in the Amazon Aurora User Guide.