IoT SiteWise OPC-UA 收集器 - Amazon IoT Greengrass
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

IoT SiteWise OPC-UA 收集器

IoT SiteWise OPC-UA 收集器组件 (aws.iot.SiteWiseEdgeCollectorOpcua) 启用Amazon IoT SiteWise网关从本地 OPC-UA 服务器收集数据。

有了这个组件,Amazon IoT SiteWise网关可以连接到多个 OPC-UA 服务器。有关 的更多信息Amazon IoT SiteWise网关,请参阅使用Amazon IoT SiteWise在边缘中的Amazon IoT SiteWise用户指南.

版本

此组件具有以下版本:

  • 2.1.x

  • 2.0.x

类型

组件是一个通用组件(aws.greengrass.generic)。这些区域有:Greengrass 核运行组件的生命周期脚本。

有关更多信息,请参阅 组件类型

操作系统

此组件只能安装在 Linux 核心设备上。

要求

此组件具有以下要求:

  • Greengrass 核心设备必须在以下一个平台上运行:

    • 操作系统:Ubuntu 20.04 或 18.04

      架构:x86_64 (AMD64)

    • 操作系统:红帽企业 Linux (RHEL) 8

      架构:x86_64 (AMD64)

    • 操作系统:Amazon Linux 2

      架构:x86_64 (AMD64)

  • Greengrass 核心设备必须允许出站网络连接到 OPC-UA 服务器。

附属物

当你部署组件时,Amazon IoT Greengrass还可以部署其依赖项的兼容版本。这意味着您必须满足组件及其所有依赖项的要求才能成功部署组件。本部分列出了的依赖项发布的版本以及定义每个依赖项的组件版本的语义版本约束。您还可以在Amazon IoT Greengrass控制台. 在组件详细信息页面上,查找依赖项列表。

下表列出了此组件的所有版本的依赖项。

依赖关系 兼容的版本 依赖项类型
Greengrass 核 >=2.3.0 <3.0.0 硬性
流管理器 >2.0.10<3.0.0 硬性
密钥管理器 >=2.0.8 <3.0.0 硬性

有关组件依赖项的更多信息,请参阅组件配方参考.

配置

此组件没有任何配置参数。

输出数据

这个组件写BatchPutAssetPropertyValue发送的消息Amazon IoT Greengrass流管理器。有关更多信息,请参阅 Amazon IoT SiteWise API 参考中的 BatchPutAssetPropertyValue

本地日志文件

此组件使用以下日志文件。

/greengrass/v2/logs/aws.iot.SiteWiseEdgeCollectorOpcua.log

查看此组件的日志

  • 在核心设备上运行以下命令以实时查看此组件的日志文件。Replace/绿草/v2随着通往Amazon IoT Greengrass根文件夹。

    sudo tail -f /greengrass/v2/logs/aws.iot.SiteWiseEdgeCollectorOpcua.log

许可证

此组件在Greengrass 核心软件许可协议.

更改日志

下表介绍了在组件各个版本中进行的更改。

Version

更改

2.1.3

错误修复和改进
  • 改进了在不受支持的设备上部署此组件时的错误消息。

2.1.1

添加对配置以下订阅属性的支持。

  • DataChangetrigger‐您可以定义启动数据更改警报的条件。

  • QueueSize‐OPC-UA 服务器上的队列深度,该指标对于被监视项目的通知排队的特定指标。

  • 发布间隔毫秒‐创建订阅时指定的发布周期的间隔(以毫秒为单位)。

  • SnapshotFvernecyMysics‐您可以配置快照频率超时设置以确保Amazon IoT SiteWiseEdge 提取了稳定的数据流。

此版本支持摄入BAD质量数据并根据以下数据质量筛选数据:

  • UNCERTAIN数据质量

  • BAD数据质量

错误修复和改进。

  • 改进了买家指标。

  • 修复了在连接到启用加密的服务器时有时会导致问题的安全编码。

  • 修复了属性组无法更新的问题。

2.0.3

错误修复和改进。

2.0.2

修复了资产优先级与边缘同步的错误和改进。

2.0.1

初始版本。

另请参阅