2019-09-19 版 Amazon Neptune 引擎更新 - Amazon Neptune
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

2019-09-19 版 Amazon Neptune 引擎更新

重要提示:此引擎版本现已弃用

从 2021-04-27 开始,将不会创建使用此引擎版本的新实例。

版本:1.0.1.0.200457.0

Amazon Neptune 1.0.1.0.200457.0 正式上市。在该区域的引擎更新完成后,将使用 Neptune 1.0.200457.0 创建所有的新 Neptune 数据库集群,包括从快照恢复的集群。

可以使用控制台上的数据库集群操作或者使用开发工具包来立即将现有集群升级到此版本。您可以使用以下 CLI 命令升级数据库集群:

aws neptune apply-pending-maintenance-action \ --apply-action system-update \ --opt-in-type immediate \ --resource-identifier arn:aws:rds:<region>:<account number>:<resourcetype>:<name>

更新将同时应用于数据库集群中的所有实例。更新需要在数据库集群中的所有实例上重新启动数据库,因此,会出现从 20 到 30 秒到几分钟的停机,之后您可以继续使用数据库集群。您可以在查看或更改维护时段设置。Neptune 控制台.

如果您有任何问题或疑虑,AmazonSupport 过社区论坛和通过AmazonPremium Support.

在此引擎版本中修复的缺陷

  • 通过删除联接谓词处理的性能改进,修复了之前引擎版本 (1.0.1.0.200369.0) 引入的 Gremlin 正确性问题。

  • 修复了导致使用 DISTINCT 的查询和将单个模式封装到 OPTIONAL 中会生成 InternalServerError 的 SPARQL 错误。