Amazon Neptune 引擎版本 1.0.1.2 - Amazon Neptune
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Amazon Neptune 引擎版本 1.0.1.2

重要提示:此引擎版本现已弃用

从 2021-04-27 开始,不会创建使用此引擎版本的新实例。

此引擎版本中的改进

  • Neptune 现在引发一个IllegalArgumentException如果您尝试访问不存在的属性、顶点或边缘,请参阅。此前,Neptune 提出了UnsupportedOperationException在这种情况下.

    例如,如果您尝试添加引用不存在顶点的边缘,则现在将引发 IllegalArgumentException

在此引擎版本中修复的缺陷

  • 修复了在有两个 value->id 映射同时插入时字典和用户事务提交顺序混乱的错误。

  • 修复了加载状态序列化中的一个错误。

  • 修复了服务器启动延迟了实例创建的随机故障。

  • 修复了游标泄漏。

此版本支持的查询语言版本

将数据库集群升级到 1.0.1.2 版之前,请确保您的项目与以下查询语言版本兼容:

  • Gemlin 版本: 3.4.1

  • SPARQL 版本: 1.1