Amazon Neptune 引擎版本 1.0.2.2.2.R5 (2020-10-12) - Amazon Neptune
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Amazon Neptune 引擎版本 1.0.2.2.2.R5 (2020-10-12)

截至 2020-10-12,引擎版本 1.0.2.2.2.R5 正在普遍部署。请注意,新版本在每个区域的发布需要几天的时间。

此引擎版本中的改进

  • 改进了 Grelin 的性能properties()Step。

  • 增加了关于BindOpMultiplexerOp在解释和个人资料报告中。

  • 对于 SPARQL 查询响应,添加了charset转到 ContentType 标头,使 HTTP 客户端能够识别自动使用的字符集。

在此引擎版本中修复的缺陷

  • 修复了 SPARQL 错误CancellationException没有处理。

  • 修复了包含嵌套可选项的查询无法正常工作的 SPARQL 错误。

  • 修复了 LOAD 中的 SPARQL 错误,ConcurrentModificationException可能会导致查询挂起。

  • 修复了导致查询响应无法被 gzip 压缩的 SPARQL 错误。

  • 修复了groupBy()Step。

  • 修复了一个与使用aggregate()单步进入local()Step。

  • 修复了一个与使用相关的 Grlin 错误bothE()然后是使用聚合值的谓词。

  • 修复了一个与使用bothE()repeat()Step。

  • 修复了与both()Step。

  • 修复了由于以 “/” 结尾的终端节点未正确处理而丢失请求指标的错误。

  • 修复了一个可能引发ThrottlingException即使请求队列不满也是如此。

  • 修复了当加载由于以下原因而失败时获取加载状态的错误LOAD_DATA_FAILED_DUE_TO_FEED_MODIFIED_OR_DELETE.

此版本支持的查询语言版本

在将数据库集群升级到版本 1.0.2.2.R5 之前,请确保您的项目与以下查询语言版本兼容:

  • Grelin 版本: 3.4.3

  • SPARQL 版本: 1.1

升级到引擎版本 1.0.2.2.R5 的路径

如果您正在运行引擎版本 1.0.2.2,您的集群将在下一个维护时段内自动升级到此补丁版本。

您可以将任何以前的 Neptune 引擎版本手动升级到此版本。

升级到此版本

Amazon Neptune 1.0.2.2.R5 现已正式上市。

如果数据库集群运行的引擎版本有此版本的升级路径,则现在有资格进行升级。您可以使用控制台上的数据库集群操作或者使用开发工具包来升级任何符合条件的集群。以下 CLI 命令将立即升级符合条件的集群:

针对 Linux、OS X 或 Unix:

aws neptune modify-db-cluster \ --db-cluster-identifier (your-neptune-cluster) \ --engine-version 1.0.2.2 \ --apply-immediately

对于 Windows:

aws neptune modify-db-cluster ^ --db-cluster-identifier (your-neptune-cluster) ^ --engine-version 1.0.2.2 ^ --apply-immediately

更新将同时应用于数据库集群中的所有实例。更新需要在这些实例上重新启动数据库,因此,会出现从 20 到 30 秒到几分钟的停机,之后您可以继续使用数据库集群。

有关升级引擎版本的更多信息,请参阅Neptune 引擎更新. 如果您有任何问题或疑虑,Amazon可 Support 过社区论坛和通过AmazonPremium Support.