Amazon Neptune 引擎版本 1.0.5.1 (2021-10-01) - Amazon Neptune
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Amazon Neptune 引擎版本 1.0.5.1 (2021-10-01)

截至 2021-10-01 年,引擎版本 1.0.5.1 正在普遍部署。请注意,新版本在每个区域的发布需要几天的时间。

此版本的后续补丁版本

此引擎版本中的新增功能

  • 增加了结果缓存用于缓存指定查询的结果。

  • 在 Neptune OpenPher 中添加了日期/时间支持。

  • 添加了对 的支持ListMap访问 Neptune OpenPher 中的元素。

此引擎版本中的改进

  • 使得 Neptune OpenPher 终端节点名称不区分大小写。

  • 改进的 OpenPher 解释说。

  • 改进的 Gremlin 单个 upsert 查询模式终止iterate()profile()步骤。

  • GEMlin 的性能提高了keys()property()函数。

  • GEMlindedup()步骤与全局范围一起使用时在 DFE 中运行。

  • 以下 GEMlinHAS启用 DFE 引擎后,谓词在 DFE 引擎中运行:

    • EQ

    • NEQ

    • LT

    • LTE

    • GT

    • GTE

    • BETWEEN

    • INSIDE

    • OUTSIDE

    • WITHIN

    • AND (connectives)

    • OR (connectives)

  • 改进了 LIMIT 查询性能。

  • 改进了 OpenPher 常规聚合查询的性能。

在此引擎版本中修复的缺陷

  • 修复了一个 Gremlin 错误,该错误允许边缘连接到另一个边缘。

  • 修复了导致选择次优联接策略的 GEMlin 错误。

  • 修复了一个 Gremlin 错误,该错误导致当存在 100 多个属性时,节点和关系的序列化停滞。

  • 修复了延缓具有大图形模式的查询的查询执行计划的错误。

此版本支持的查询语言版本

在将数据库集群升级到版本 1.0.5.1 之前,请确保您的项目与以下查询语言版本兼容:

  • GEMlin 版本: 3.4.11

  • SPARQL 版本: 1.1

升级到引擎版本 1.0.5.1 的路径

您可以将任何以前的 Neptune 引擎版本手动升级到此版本。

您不会自动升级到此版本。

升级到此版本

Amazon Neptune 1.0.5.1 现已正式上市。

如果数据库集群运行的引擎版本有此版本的升级路径,则现在有资格进行升级。您可以使用控制台上的数据库群集操作或者使用开发工具包来升级任何符合条件的集群。以下 CLI 命令将立即升级符合条件的集群:

针对 Linux、OS X 或 Unix:

aws neptune modify-db-cluster \ --db-cluster-identifier (your-neptune-cluster) \ --engine-version 1.0.5.1 \ --apply-immediately

对于 Windows:

aws neptune modify-db-cluster ^ --db-cluster-identifier (your-neptune-cluster) ^ --engine-version 1.0.5.1 ^ --apply-immediately

更新将同时应用于数据库集群中的所有实例。更新需要在这些实例上重新启动数据库,因此,会出现从 20 到 30 秒到几分钟的停机,之后您可以继续使用数据库集群。

有关升级引擎版本的更多信息,请参阅Neptune 引擎更新. 如果您有任何问题或疑虑,Amazon可通过社区论坛和通过以下方式联系 Support 团队AmazonPremium Support.