Image 部分 - Amazon ParallelCluster
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Image 部分

必需需定义集群的操作系统。

Image: Os: string CustomAmi: string

Image属性

Os(必需,String)

指定用于集群的操作系统。支持的值为alinux2,centos7,ubuntu1804,以及ubuntu2004.

下表中提到的不支持的特定区域除外centos7. 必需需设置Amazon商业区域支持以下所有操作系统。

分区(区域) alinux2 centos7 ubuntu1804ubuntu2004
商业(未特别提及所有区域) True True True
Amazon GovCloud (美国东部)us-gov-east-1) True False True
Amazon GovCloud (美国西部)us-gov-west-1) True False True
中国(北京) (cn-north-1) True False True
中国(宁夏) (cn-northwest-1) True False True

更新策略:如果更改此设置,则不允许更新。

CustomAmi(可选,String)

指定用于头部和计算节点的自定义 AMI 的 ID,而不是默认 AMI。有关更多信息,请参阅 Amazon ParallelClusterAMI 自定义

如果自定义 AMI 需要额外的启动权限,则必须将这些权限同时添加到用户和头节点策略中。

例如,如果自定义 AMI 有与之关联的加密快照,则用户和头节点策略中都需要以下额外策略:

{ "Version": "2012-10-17", "Statement": [ { "Effect": "Allow", "Action": [ "kms:DescribeKey", "kms:ReEncrypt*", "kms:CreateGrant", "kms:Decrypt" ], "Resource": [ "arn:aws:kms:<AWS_REGION>:<AWS_ACCOUNT_ID>:key/<AWS_KMS_KEY_ID>" ] } ] }

要解决自定义 AMI 验证警告,请参阅排查自定义 AMI 问题.

更新策略:如果更改此设置,则不允许更新。