启用 Intel MPI - Amazon ParallelCluster
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

启用 Intel MPI

英特尔 MPI 可在Amazon ParallelClusterAMIalinux2,centos7,ubuntu1804,以及ubuntu2004字段Image/Os设置。

注意

要使用英特尔 MPI,您必须确认并接受英特尔简化软件许可证.

默认情况下,Open MPI 位于路径上。要启用英特尔 MPI 而不是 Open MPI,必须先加载英特尔 MPI 模块。然后,您需要使用安装最新版本module load intelmpi. 模块的确切名称随每次更新发生变化。要查看哪些模块可用,请运行 module avail。输出如下所示。

$ module avail -----------------------------/usr/share/Modules/modulefiles -------------------------------- dot modules libfabric-aws/1.16.0~amzn3.0 null module-git openmpi/4.1.4 module-info use.own -----------------------------/opt/intel/mpi/2021.6.0/modulefiles --------------------------- intelmpi

要加载模块,请运行 module load modulename。您可以将其添加到用于运行 mpirun 的脚本中。

$ module load intelmpi

要查看加载了哪些模块,请运行module list.

$ module list Currently Loaded Modulefiles: 1) intelmpi

要验证是否已启用 Intel MPI,请运行 mpirun --version

$ mpirun --version Intel(R) MPI Library for Linux* OS, Version 2021.6 Build 20220227 (id: 28877f3f32) Copyright 2003-2022, Intel Corporation.

加载 Intel MPI 模块后,将更改多个路径以使用 Intel MPI 工具。要运行由英特尔 MPI 工具编译的代码,请先加载英特尔 MPI 模块。

注意

英特尔 MPI 与不兼容Amazon基于引力的实例。

注意

之前Amazon ParallelCluster版本 2.0,Intel MPI 已在Amazon ParallelClusterAMI 位于中国(北京)和中国(宁夏)区域。