什么是?Amazon SDK for PHP版本 3? - Amazon SDK for PHP
Amazon Web Services 文档中描述的 Amazon Web Services 服务或功能可能因区域而异。要查看适用于中国区域的差异,请参阅中国的 Amazon Web Services 服务入门

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

什么是?Amazon SDK for PHP版本 3?

这些区域有:Amazon SDK for PHP版本 3 使 PHP 开发人员能够使用Amazon Web Services并使用诸如 Amazon S3、Amazon DynamoDB、S3 Glacier 等服务构建稳健的应用程序和软件。您可以在几分钟内开始使用 Composer 安装开发工具包,方法是要求aws/aws-sdk-php软件包 — 或者通过下载独立aws.zip要么aws.phar文件。

开发工具包中的服务并不是全部直接可用的。要了解Amazon SDK for PHP目前支持哪些服务,请参阅服务名称和 API 版本。有关在 GitHub 上使用Amazon SDK for PHP版本 3 的信息,请参阅其他资源

注意

如果您希望将使用版本 2 开发工具包代码迁移到版本 3,请务必阅读从的版本 2 升级Amazon SDK for PHP.

入门

开发工具包指南

适用于特定服务的功能

示例

有关其他示例,请参阅Amazon代码示例目录.

参考

在 GitHub 上提交问题:

API 文档

在此处查找适用于的 API 文档https://docs.aws.amazon.com/sdk-for-php/latest/reference/.

开发工具包主要版本的维护和支持

有关维护和支持开发工具包主要版本及其基础依赖关系的信息,请参阅Amazon开发工具包和工具共享配置和凭据参考指南